Unspecified vulnerability in the "dependency resolution mechanism" in Ruby on Rails 1.1.0…
Priority LOW 38Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
Unspecified vulnerability in the "dependency resolution mechanism" in Ruby on Rails 1.1.0 through 1.1.5 allows remote attackers to execute arbitrary Ruby code via a URL that is not properly handled in the routing code, which leads to a denial of service (application hang) or "data loss," a different vulnerability than CVE-2006-4111.
Why it matters now
EPSS 0.03121 87th percentileScored 2026-11-07
Fix Fixed rails (RubyGems): 1.1.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | rails (RubyGems) | 1.1.0 to before 1.1.6 | 1.1.6 | Patch available | GHSA-9wrq-xvmp-xjc8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- rails (RubyGems) Vendor— Affected 1.1.0 to before 1.1.6 Fixed in 1.1.6 Patch available GHSA-9wrq-xvmp-xjc8
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyonrails:rails:1.1.0:*:*:*:*:*:*:* | 1.1.0 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:1.1.1:*:*:*:*:*:*:* | 1.1.1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:1.1.2:*:*:*:*:*:*:* | 1.1.2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:1.1.3:*:*:*:*:*:*:* | 1.1.3 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:1.1.4:*:*:*:*:*:*:* | 1.1.4 | Vulnerable | Rails |
- cpe:2.3:a:rubyonrails:rails:1.1.0:*:*:*:*:*:*:* Versions 1.1.0 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:1.1.1:*:*:*:*:*:*:* Versions 1.1.1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:1.1.2:*:*:*:*:*:*:* Versions 1.1.2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:1.1.3:*:*:*:*:*:*:* Versions 1.1.3 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:1.1.4:*:*:*:*:*:*:* Versions 1.1.4 Vulnerable ·Rails
Remediation
- Fix · GHSA-9wrq-xvmp-xjc8 rails (RubyGems) Fixed in 1.1.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2006-4112
- 2026-10-03 Alias added: GHSA-9wrq-xvmp-xjc8
References
Patch 3
Other 5
- https://github.com/rails/rails
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rails/CVE-2006-4112.yml
- https://web.archive.org/web/20200301174340/http://www.securityfocus.com/bid/19454
- https://web.archive.org/web/20200804225700/http://www.securityfocus.com/archive/1/442934/100/0/threaded
- https://web.archive.org/web/20200808083046/http://securitytracker.com/id?1016673
More Rails vulnerabilities
- TI-2014-00124 Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the… KEVCVSS 3.1HIGH 7.5
- TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
- TI-2016-00672 Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x… KEVCVSS 3.1HIGH 7.5
- TI-2019-03830 Command injection in Rails https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
- TI-2020-06581 Code injection in https://github.com/rails/rails CVSS 3.1HIGH 8.8
- TI-2013-00091 active_support/core_ext/hash/conversions.rb in Ruby on Rails before 2.3.15, 3.0.x before… CVSS 2.0HIGH 7.5
Sources
- CVE-2006-4112 · CVE Program
- CVE-2006-4112 · NVD
- FIRST EPSS
- GHSA-9wrq-xvmp-xjc8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences