PreviewAction in XWiki 0.9.543 through 0.9.1252 does not set the Author field to the…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
PreviewAction in XWiki 0.9.543 through 0.9.1252 does not set the Author field to the identity of the user who last modified a document, which allows remote authenticated users without programming rights to execute arbitrary code by selecting a document whose author has programming rights, modifying this document to contain a script, and previewing without saving the document.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.xwiki.platform:xwiki-platform-oldcore (Maven) | 0.9.543 to before 1.0B1 | 1.0B1 | Patch available | GHSA-h5jm-jjgx-q2wf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.xwiki.platform:xwiki-platform-oldcore (Maven) Vendor— Affected 0.9.543 to before 1.0B1 Fixed in 1.0B1 Patch available GHSA-h5jm-jjgx-q2wf
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:xwiki:xwiki:0.9.543:*:*:*:*:*:*:* | 0.9.543 | Vulnerable | XWiki |
| cpe:2.3:a:xwiki:xwiki:0.9.790:*:*:*:*:*:*:* | 0.9.790 | Vulnerable | XWiki |
| cpe:2.3:a:xwiki:xwiki:0.9.793:*:*:*:*:*:*:* | 0.9.793 | Vulnerable | XWiki |
| cpe:2.3:a:xwiki:xwiki:0.9.840:*:*:*:*:*:*:* | 0.9.840 | Vulnerable | XWiki |
| cpe:2.3:a:xwiki:xwiki:0.9.1252:*:*:*:*:*:*:* | 0.9.1252 | Vulnerable | XWiki |
- cpe:2.3:a:xwiki:xwiki:0.9.543:*:*:*:*:*:*:* Versions 0.9.543 Vulnerable ·XWiki
- cpe:2.3:a:xwiki:xwiki:0.9.790:*:*:*:*:*:*:* Versions 0.9.790 Vulnerable ·XWiki
- cpe:2.3:a:xwiki:xwiki:0.9.793:*:*:*:*:*:*:* Versions 0.9.793 Vulnerable ·XWiki
- cpe:2.3:a:xwiki:xwiki:0.9.840:*:*:*:*:*:*:* Versions 0.9.840 Vulnerable ·XWiki
- cpe:2.3:a:xwiki:xwiki:0.9.1252:*:*:*:*:*:*:* Versions 0.9.1252 Vulnerable ·XWiki
Remediation
- Fix · GHSA-h5jm-jjgx-q2wf org.xwiki.platform:xwiki-platform-oldcore (Maven) Fixed in 1.0B1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2006-7223
- 2026-10-03 Alias added: GHSA-h5jm-jjgx-q2wf
References
More Xwiki vulnerabilities
- TI-2025-18595 Remote code execution as guest via SolrSearchMacros request in xwiki KEVCVSS 3.1CRITICAL 9.8
- TI-2023-25214 Remote code execution through the section parameter in Administration as guest in XWiki Platform CVSS 3.1CRITICAL 10.0
- TI-2025-23500 XWiki Platform vulnerable to SQL injection through getdeleteddocuments.vm template sort parameter CVSS 4.0CRITICAL 9.3
- TI-2025-23979 org.xwiki.platform:xwiki-platform-rest-server allows SQL injection in query endpoint of REST API CVSS 4.0CRITICAL 9.3
- TI-2024-20829 XWiki Platform: Remote code execution from account via SearchSuggestSourceSheet CVSS 3.1CRITICAL 10.0
- TI-2024-14375 XWiki Remote Code Execution vulnerability via user registration CVSS 3.1CRITICAL 10.0
Sources
- CVE-2006-7223 · CVE Program
- CVE-2006-7223 · NVD
- FIRST EPSS
- GHSA-h5jm-jjgx-q2wf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences