Read the docs
TI-2007-00480 Aliases CVE-2007-0493GHSA-p6fj-c7mp-96mv

Use-after-free vulnerability in ISC BIND 9.3.0 up to 9.3.3, 9.4.0a1 up to 9.4.0a6…

Priority MEDIUM 48Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · Complete
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat.

Summary

Use-after-free vulnerability in ISC BIND 9.3.0 up to 9.3.3, 9.4.0a1 up to 9.4.0a6, 9.4.0b1 up to 9.4.0b4, 9.4.0rc1, and 9.5.0a1 (Bind Forum only) allows remote attackers to cause a denial of service (named daemon crash) via unspecified vectors that cause named to "dereference a freed fetch context."

Why it matters now

EPSS 0.12768 96th percentileScored 2026-11-07
Fix Fixed Red Hat: 1 advisory

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.3.0:*:*:*:*:*:*:*9.3.0VulnerableISC
cpe:2.3:a:isc:bind:9.3.1:*:*:*:*:*:*:*9.3.1VulnerableISC
cpe:2.3:a:isc:bind:9.3.2:*:*:*:*:*:*:*9.3.2VulnerableISC
cpe:2.3:a:isc:bind:9.4.0:*:*:*:*:*:*:*9.4.0VulnerableISC
cpe:2.3:a:isc:bind:9.4.0:rc1:*:*:*:*:*:*9.4.0 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.5.0:*:*:*:*:*:*:*9.5.0VulnerableISC
  • cpe:2.3:a:isc:bind:9.3.0:*:*:*:*:*:*:* Versions 9.3.0 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.3.1:*:*:*:*:*:*:* Versions 9.3.1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.3.2:*:*:*:*:*:*:* Versions 9.3.2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.4.0:*:*:*:*:*:*:* Versions 9.4.0 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.4.0:rc1:*:*:*:*:*:* Versions 9.4.0 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.5.0:*:*:*:*:*:*:* Versions 9.5.0 Vulnerable ·ISC

Remediation

Red Hat 1 advisory

  • RHSA-2007:0057 Released 2007-03-14 · Red Hat rating Moderate
    bind security update
    • Red Hat Enterprise Linux (v. 5 server) bind-30:9.3.3-8.el5, bind-30:9.3.3-8.el5.i386, bind-30:9.3.3-8.el5.ia64 +29
    • Red Hat Enterprise Linux Desktop (v. 5 client) bind-30:9.3.3-8.el5, bind-30:9.3.3-8.el5.i386, bind-libs-30:9.3.3-8.el5 +5
    • Red Hat Enterprise Linux Desktop Workstation (v. 5 client) bind-30:9.3.3-8.el5, bind-chroot-30:9.3.3-8.el5, bind-chroot-30:9.3.3-8.el5.i386 +6

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux (v. 5 server)Fixed RHSA-2007:0057
Red Hat Enterprise Linux Desktop (v. 5 client)Fixed RHSA-2007:0057
Red Hat Enterprise Linux Desktop Workstation (v. 5 client)Fixed RHSA-2007:0057

Timeline

  1. 2026-10-02 Threatist record created from CVE-2007-0493
  2. 2026-10-03 Alias added: GHSA-p6fj-c7mp-96mv

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources