ISC BIND 9 through 9.5.0a5 uses a weak random number generator during generation of DNS…
Priority LOW 35Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- —
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat.
Summary
ISC BIND 9 through 9.5.0a5 uses a weak random number generator during generation of DNS query ids when answering resolver questions or sending NOTIFY messages to slave name servers, which makes it easier for remote attackers to guess the next query id and perform DNS cache poisoning.
Why it matters now
EPSS 0.1309 96th percentileScored 2026-11-07
Fix Fixed Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:isc:bind:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.1:*:*:*:*:*:*:* | 9.1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.2:*:*:*:*:*:*:* | 9.2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.3:*:*:*:*:*:*:* | 9.3 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.4:*:*:*:*:*:*:* | 9.4 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.5:*:*:*:*:*:*:* | 9.5 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.5.0:*:*:*:*:*:*:* | 9.5.0 | Vulnerable | ISC |
- cpe:2.3:a:isc:bind:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.1:*:*:*:*:*:*:* Versions 9.1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.2:*:*:*:*:*:*:* Versions 9.2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.3:*:*:*:*:*:*:* Versions 9.3 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.4:*:*:*:*:*:*:* Versions 9.4 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.5:*:*:*:*:*:*:* Versions 9.5 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.5.0:*:*:*:*:*:*:* Versions 9.5.0 Vulnerable ·ISC
Remediation
Red Hat 1 advisory
- RHSA-2007:0740 Released 2007-07-24 · Red Hat rating Moderatebind security update
- Red Hat Desktop version 3 bind-20:9.2.4-21.el3, bind-20:9.2.4-21.el3.i386, bind-chroot-20:9.2.4-21.el3 +7
- Red Hat Enterprise Linux (v. 5 server) bind-30:9.3.3-9.0.1.el5, bind-30:9.3.3-9.0.1.el5.i386, bind-30:9.3.3-9.0.1.el5.ia64 +29
- Red Hat Enterprise Linux AS (Advanced Server) version 2.1 bind-9.2.1-9.el2, bind-9.2.1-9.el2.i386, bind-9.2.1-9.el2.ia64 +4
- Red Hat Enterprise Linux AS version 3 bind-20:9.2.4-21.el3, bind-20:9.2.4-21.el3.i386, bind-20:9.2.4-21.el3.ia64 +17
- Red Hat Enterprise Linux AS version 4 bind-20:9.2.4-27.0.1.el4, bind-20:9.2.4-27.0.1.el4.i386, bind-20:9.2.4-27.0.1.el4.ia64 +17
- Red Hat Enterprise Linux Desktop (v. 5 client) bind-30:9.3.3-9.0.1.el5, bind-30:9.3.3-9.0.1.el5.i386, bind-libs-30:9.3.3-9.0.1.el5 +5
- Red Hat Enterprise Linux Desktop Workstation (v. 5 client) bind-30:9.3.3-9.0.1.el5, bind-chroot-30:9.3.3-9.0.1.el5, bind-chroot-30:9.3.3-9.0.1.el5.i386 +6
- Red Hat Enterprise Linux Desktop version 4 bind-20:9.2.4-27.0.1.el4, bind-20:9.2.4-27.0.1.el4.i386, bind-chroot-20:9.2.4-27.0.1.el4 +7
- Red Hat Enterprise Linux ES version 2.1 bind-9.2.1-9.el2, bind-9.2.1-9.el2.i386, bind-devel-9.2.1-9.el2.i386 +1
- Red Hat Enterprise Linux ES version 3 bind-20:9.2.4-21.el3, bind-20:9.2.4-21.el3.i386, bind-20:9.2.4-21.el3.ia64 +12
- Red Hat Enterprise Linux ES version 4 bind-20:9.2.4-27.0.1.el4, bind-20:9.2.4-27.0.1.el4.i386, bind-20:9.2.4-27.0.1.el4.ia64 +12
- Red Hat Enterprise Linux WS version 2.1 bind-9.2.1-9.el2, bind-9.2.1-9.el2.i386, bind-devel-9.2.1-9.el2.i386 +1
- Red Hat Enterprise Linux WS version 3 bind-20:9.2.4-21.el3, bind-20:9.2.4-21.el3.i386, bind-20:9.2.4-21.el3.ia64 +12
- Red Hat Enterprise Linux WS version 4 bind-20:9.2.4-27.0.1.el4, bind-20:9.2.4-27.0.1.el4.i386, bind-20:9.2.4-27.0.1.el4.ia64 +12
- Red Hat Linux Advanced Workstation 2.1 bind-9.2.1-9.el2, bind-9.2.1-9.el2.ia64, bind-devel-9.2.1-9.el2.ia64 +1
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Desktop version 3 | Fixed | RHSA-2007:0740 |
| Red Hat Enterprise Linux (v. 5 server) | Fixed | RHSA-2007:0740 |
| Red Hat Enterprise Linux AS (Advanced Server) version 2.1 | Fixed | RHSA-2007:0740 |
| Red Hat Enterprise Linux AS version 3 | Fixed | RHSA-2007:0740 |
| Red Hat Enterprise Linux AS version 4 | Fixed | RHSA-2007:0740 |
| Red Hat Enterprise Linux Desktop (v. 5 client) | Fixed | RHSA-2007:0740 |
| Red Hat Enterprise Linux Desktop Workstation (v. 5 client) | Fixed | RHSA-2007:0740 |
| Red Hat Enterprise Linux Desktop version 4 | Fixed | RHSA-2007:0740 |
| Red Hat Enterprise Linux ES version 2.1 | Fixed | RHSA-2007:0740 |
| Red Hat Enterprise Linux ES version 3 | Fixed | RHSA-2007:0740 |
| Red Hat Enterprise Linux ES version 4 | Fixed | RHSA-2007:0740 |
| Red Hat Enterprise Linux WS version 2.1 | Fixed | RHSA-2007:0740 |
| Red Hat Enterprise Linux WS version 3 | Fixed | RHSA-2007:0740 |
| Red Hat Enterprise Linux WS version 4 | Fixed | RHSA-2007:0740 |
| Red Hat Linux Advanced Workstation 2.1 | Fixed | RHSA-2007:0740 |
Timeline
- 2026-10-02 Threatist record created from CVE-2007-2926
- 2026-10-03 Alias added: GHSA-f6h8-pjrf-562j
References
Advisory 20
Other 17
- http://support.avaya.com/elmodocs2/security/ASA-2007-389.htm
- http://www.trusteer.com/docs/bind9dns_s.html
- ADV-2007-2932
- ADV-2007-2914
- http://www.securiteam.com/securitynews/5VP0L0UM0A.html
- http://www.trusteer.com/docs/bind9dns.html
- http://support.nortel.com/go/main.jsp?cscat=BLTNDETAIL&id=623903
- http://docs.info.apple.com/article.html?artnum=307041
- http://www.isc.org/index.pl?/sw/bind/bind-security.php
- ADV-2007-2782
- ADV-2007-3868
- https://issues.rpath.com/browse/RPL-1587
- ADV-2007-2627
- oval:org.mitre.oval:def:2226
- ADV-2007-2662
- ADV-2007-3242
- oval:org.mitre.oval:def:10293
More ISC Bind vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
- TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
Sources
- CVE-2007-2926 · CVE Program
- CVE-2007-2926 · NVD
- FIRST EPSS
- GHSA-f6h8-pjrf-562j · GitHub Advisory Database · CC BY 4.0
- CVE-2007-2926 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences