Cross-site scripting (XSS) vulnerability in Dump Servlet in Mortbay Jetty before 6.1.6rc1…
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in Dump Servlet in Mortbay Jetty before 6.1.6rc1 allows remote attackers to inject arbitrary web script or HTML via unspecified parameters and cookies.
Why it matters now
EPSS 0.02893 86th percentileScored 2026-11-07
Fix Fixed org.mortbay.jetty:jetty (Maven): 6.1.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.mortbay.jetty:jetty (Maven) | before 6.1.6 | 6.1.6 | Patch available | GHSA-8h77-9vh5-hw5g |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.mortbay.jetty:jetty (Maven) Vendor— Affected before 6.1.6 Fixed in 6.1.6 Patch available GHSA-8h77-9vh5-hw5g
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mortbay_jetty:jetty:1.0:*:*:*:*:*:*:* | 1.0 | Vulnerable | Mortbay Jetty |
| cpe:2.3:a:mortbay_jetty:jetty:2.4:*:*:*:*:*:*:* | 2.4 | Vulnerable | Mortbay Jetty |
| cpe:2.3:a:mortbay_jetty:jetty:3.0:*:*:*:*:*:*:* | 3.0 | Vulnerable | Mortbay Jetty |
| cpe:2.3:a:mortbay_jetty:jetty:3.1:*:*:*:*:*:*:* | 3.1 | Vulnerable | Mortbay Jetty |
| cpe:2.3:a:mortbay_jetty:jetty:4.0:*:*:*:*:*:*:* | 4.0 | Vulnerable | Mortbay Jetty |
| cpe:2.3:a:mortbay_jetty:jetty:4.1:*:*:*:*:*:*:* | 4.1 | Vulnerable | Mortbay Jetty |
| cpe:2.3:a:mortbay_jetty:jetty:4.2:*:*:*:*:*:*:* | 4.2 | Vulnerable | Mortbay Jetty |
| cpe:2.3:a:mortbay_jetty:jetty:5:*:*:*:*:*:*:* | 5 | Vulnerable | Mortbay Jetty |
| cpe:2.3:a:mortbay_jetty:jetty:5.1:*:*:*:*:*:*:* | 5.1 | Vulnerable | Mortbay Jetty |
| cpe:2.3:a:mortbay_jetty:jetty:6:*:*:*:*:*:*:* | 6 | Vulnerable | Mortbay Jetty |
- cpe:2.3:a:mortbay_jetty:jetty:1.0:*:*:*:*:*:*:* Versions 1.0 Vulnerable ·Mortbay Jetty
- cpe:2.3:a:mortbay_jetty:jetty:2.4:*:*:*:*:*:*:* Versions 2.4 Vulnerable ·Mortbay Jetty
- cpe:2.3:a:mortbay_jetty:jetty:3.0:*:*:*:*:*:*:* Versions 3.0 Vulnerable ·Mortbay Jetty
- cpe:2.3:a:mortbay_jetty:jetty:3.1:*:*:*:*:*:*:* Versions 3.1 Vulnerable ·Mortbay Jetty
- cpe:2.3:a:mortbay_jetty:jetty:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·Mortbay Jetty
- cpe:2.3:a:mortbay_jetty:jetty:4.1:*:*:*:*:*:*:* Versions 4.1 Vulnerable ·Mortbay Jetty
- cpe:2.3:a:mortbay_jetty:jetty:4.2:*:*:*:*:*:*:* Versions 4.2 Vulnerable ·Mortbay Jetty
- cpe:2.3:a:mortbay_jetty:jetty:5:*:*:*:*:*:*:* Versions 5 Vulnerable ·Mortbay Jetty
- cpe:2.3:a:mortbay_jetty:jetty:5.1:*:*:*:*:*:*:* Versions 5.1 Vulnerable ·Mortbay Jetty
- cpe:2.3:a:mortbay_jetty:jetty:6:*:*:*:*:*:*:* Versions 6 Vulnerable ·Mortbay Jetty
Show 1 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mortbay_jetty:jetty:6.1:*:*:*:*:*:*:* | 6.1 | Vulnerable | Mortbay Jetty |
- cpe:2.3:a:mortbay_jetty:jetty:6.1:*:*:*:*:*:*:* Versions 6.1 Vulnerable ·Mortbay Jetty
Remediation
- Fix · GHSA-8h77-9vh5-hw5g org.mortbay.jetty:jetty (Maven) Fixed in 6.1.6 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2007-5613
- 2026-10-03 Alias added: GHSA-8h77-9vh5-hw5g
References
More Mortbay Jetty Jetty vulnerabilities
- TI-2007-05395 Mortbay Jetty before 6.1.6rc1 does not properly handle "certain quote sequences" in HTML… CVSS 2.0HIGH 7.5
- TI-2007-06368 Mortbay Jetty 6.1.5 and 6.1.6 allows remote attackers to bypass protection mechanisms and… CVSS 2.0MEDIUM 5.0
- TI-2007-05396 CRLF injection vulnerability in Mortbay Jetty before 6.1.6rc0 allows remote attackers to… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2007-5613 · CVE Program
- CVE-2007-5613 · NVD
- FIRST EPSS
- GHSA-8h77-9vh5-hw5g · GitHub Advisory Database · CC BY 4.0
- CVE-2007-5613 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences