The Hackers Diet Plugin HTTP POST Request ajax_blurb.php sql injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
A vulnerability, which was classified as critical, has been found in The Hackers Diet Plugin up to 0.9.6b on WordPress. This issue affects some unknown processing of the file ajax_blurb.php of the component HTTP POST Request Handler. The manipulation of the argument user leads to sql injection. The attack may be initiated remotely. Upgrading to version 0.9.7b is able to address this issue. The patch is named 7dd8acf7cd8442609840037121074425d363b694. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-243803.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | The Hackers Diet Plugin | 0.9.6b | — | No fix listed | CNA |
- The Hackers Diet Plugin Vendor— Affected 0.9.6b Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wp-plugins:the_hackers_diet:*:*:*:*:*:wordpress:*:* | before 0.9.7b | Vulnerable | Wp-plugins |
- cpe:2.3:a:wp-plugins:the_hackers_diet:*:*:*:*:*:wordpress:*:* Versions before 0.9.7b Vulnerable ·Wp-plugins
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2007-10003
- 2026-10-03 Alias added: GHSA-24m5-fqmm-mrmv
- 2026-10-29 EPSS moved to the 50th–90th percentile
References
Sources
- CVE-2007-10003 · CVE Program
- CVE-2007-10003 · NVD
- FIRST EPSS
- GHSA-24m5-fqmm-mrmv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences