Read the docs
TI-2008-00112 Aliases CVE-2008-0122GHSA-qfv4-7qhr-3fj9

Off-by-one error in the inet_network function in libbind in ISC BIND 9.4.2 and earlier…

Priority MEDIUM 57CWE-189Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
Complete · Complete · Complete
Fix status
Partial Red Hat: 3 fixed, 1 without a fix

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-189 and the CVSS impact.

Summary

Off-by-one error in the inet_network function in libbind in ISC BIND 9.4.2 and earlier, as used in libc in FreeBSD 6.2 through 7.0-PRERELEASE, allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted input that triggers memory corruption.

Why it matters now

EPSS 0.12399 96th percentileScored 2026-11-07
Fix Partial Red Hat: 1 advisoryRed Hat: 3 fixed, 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 43

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*up to 9.4.2VulnerableISC
cpe:2.3:o:freebsd:freebsd:6.2:-:*:*:*:*:*:*6.2Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.2:p1:*:*:*:*:*:*6.2 p1Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.2:p10:*:*:*:*:*:*6.2 p10Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.2:p11:*:*:*:*:*:*6.2 p11Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.2:p12:*:*:*:*:*:*6.2 p12Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.2:p4:*:*:*:*:*:*6.2 p4Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.2:p5:*:*:*:*:*:*6.2 p5Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.2:p6:*:*:*:*:*:*6.2 p6Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.2:p7:*:*:*:*:*:*6.2 p7Running onFreeBSD
  • cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:* Versions up to 9.4.2 Vulnerable ·ISC
  • cpe:2.3:o:freebsd:freebsd:6.2:-:*:*:*:*:*:* Versions 6.2 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.2:p1:*:*:*:*:*:* Versions 6.2 p1 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.2:p10:*:*:*:*:*:* Versions 6.2 p10 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.2:p11:*:*:*:*:*:* Versions 6.2 p11 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.2:p12:*:*:*:*:*:* Versions 6.2 p12 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.2:p4:*:*:*:*:*:* Versions 6.2 p4 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.2:p5:*:*:*:*:*:* Versions 6.2 p5 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.2:p6:*:*:*:*:*:* Versions 6.2 p6 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.2:p7:*:*:*:*:*:* Versions 6.2 p7 Running on ·FreeBSD
Show 33 more CPE
CPEVersionsRoleVendor
cpe:2.3:o:freebsd:freebsd:6.2:p8:*:*:*:*:*:*6.2 p8Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.2:p9:*:*:*:*:*:*6.2 p9Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.2:rc1:*:*:*:*:*:*6.2 rc1Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.2:rc2:*:*:*:*:*:*6.2 rc2Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:-:*:*:*:*:*:*6.3Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:p1:*:*:*:*:*:*6.3 p1Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:p10:*:*:*:*:*:*6.3 p10Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:p11:*:*:*:*:*:*6.3 p11Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:p12:*:*:*:*:*:*6.3 p12Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:p13:*:*:*:*:*:*6.3 p13Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:p14:*:*:*:*:*:*6.3 p14Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:p15:*:*:*:*:*:*6.3 p15Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:p2:*:*:*:*:*:*6.3 p2Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:p3:*:*:*:*:*:*6.3 p3Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:p4:*:*:*:*:*:*6.3 p4Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:p5:*:*:*:*:*:*6.3 p5Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:p6:*:*:*:*:*:*6.3 p6Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:p7:*:*:*:*:*:*6.3 p7Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:p8:*:*:*:*:*:*6.3 p8Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:p9:*:*:*:*:*:*6.3 p9Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.3:rc2:*:*:*:*:*:*6.3 rc2Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.4:-:*:*:*:*:*:*6.4Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.4:p1:*:*:*:*:*:*6.4 p1Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.4:p10:*:*:*:*:*:*6.4 p10Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.4:p11:*:*:*:*:*:*6.4 p11Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.4:p2:*:*:*:*:*:*6.4 p2Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.4:p3:*:*:*:*:*:*6.4 p3Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.4:p4:*:*:*:*:*:*6.4 p4Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.4:p5:*:*:*:*:*:*6.4 p5Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.4:p6:*:*:*:*:*:*6.4 p6Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.4:p7:*:*:*:*:*:*6.4 p7Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.4:p8:*:*:*:*:*:*6.4 p8Running onFreeBSD
cpe:2.3:o:freebsd:freebsd:6.4:p9:*:*:*:*:*:*6.4 p9Running onFreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.2:p8:*:*:*:*:*:* Versions 6.2 p8 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.2:p9:*:*:*:*:*:* Versions 6.2 p9 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.2:rc1:*:*:*:*:*:* Versions 6.2 rc1 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.2:rc2:*:*:*:*:*:* Versions 6.2 rc2 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:-:*:*:*:*:*:* Versions 6.3 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:p1:*:*:*:*:*:* Versions 6.3 p1 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:p10:*:*:*:*:*:* Versions 6.3 p10 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:p11:*:*:*:*:*:* Versions 6.3 p11 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:p12:*:*:*:*:*:* Versions 6.3 p12 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:p13:*:*:*:*:*:* Versions 6.3 p13 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:p14:*:*:*:*:*:* Versions 6.3 p14 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:p15:*:*:*:*:*:* Versions 6.3 p15 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:p2:*:*:*:*:*:* Versions 6.3 p2 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:p3:*:*:*:*:*:* Versions 6.3 p3 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:p4:*:*:*:*:*:* Versions 6.3 p4 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:p5:*:*:*:*:*:* Versions 6.3 p5 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:p6:*:*:*:*:*:* Versions 6.3 p6 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:p7:*:*:*:*:*:* Versions 6.3 p7 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:p8:*:*:*:*:*:* Versions 6.3 p8 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:p9:*:*:*:*:*:* Versions 6.3 p9 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.3:rc2:*:*:*:*:*:* Versions 6.3 rc2 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.4:-:*:*:*:*:*:* Versions 6.4 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.4:p1:*:*:*:*:*:* Versions 6.4 p1 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.4:p10:*:*:*:*:*:* Versions 6.4 p10 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.4:p11:*:*:*:*:*:* Versions 6.4 p11 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.4:p2:*:*:*:*:*:* Versions 6.4 p2 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.4:p3:*:*:*:*:*:* Versions 6.4 p3 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.4:p4:*:*:*:*:*:* Versions 6.4 p4 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.4:p5:*:*:*:*:*:* Versions 6.4 p5 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.4:p6:*:*:*:*:*:* Versions 6.4 p6 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.4:p7:*:*:*:*:*:* Versions 6.4 p7 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.4:p8:*:*:*:*:*:* Versions 6.4 p8 Running on ·FreeBSD
  • cpe:2.3:o:freebsd:freebsd:6.4:p9:*:*:*:*:*:* Versions 6.4 p9 Running on ·FreeBSD

Remediation

Red Hat 1 advisory

  • RHSA-2008:0300 Released 2008-05-20 · Red Hat rating Moderate
    bind security, bug fix, and enhancement update
    • Red Hat Enterprise Linux (v. 5 server) bind-30:9.3.4-6.P1.el5, bind-30:9.3.4-6.P1.el5.i386, bind-30:9.3.4-6.P1.el5.ia64 +29
    • Red Hat Enterprise Linux Desktop (v. 5 client) bind-30:9.3.4-6.P1.el5, bind-30:9.3.4-6.P1.el5.i386, bind-libs-30:9.3.4-6.P1.el5 +5
    • Red Hat Enterprise Linux Desktop Workstation (v. 5 client) bind-30:9.3.4-6.P1.el5, bind-chroot-30:9.3.4-6.P1.el5, bind-chroot-30:9.3.4-6.P1.el5.i386 +6

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 4AffectedNo fix yet
Red Hat Enterprise Linux (v. 5 server)Fixed RHSA-2008:0300
Red Hat Enterprise Linux Desktop (v. 5 client)Fixed RHSA-2008:0300
Red Hat Enterprise Linux Desktop Workstation (v. 5 client)Fixed RHSA-2008:0300

Timeline

  1. 2026-10-02 Threatist record created from CVE-2008-0122
  2. 2026-10-03 Alias added: GHSA-qfv4-7qhr-3fj9

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources