Directory traversal vulnerability in cmsimple/cms.php in CMSimple 3.1, when…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- No fix listed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA.
Summary
Directory traversal vulnerability in cmsimple/cms.php in CMSimple 3.1, when register_globals is enabled, allows remote attackers to include and execute arbitrary local files via a .. (dot dot) in the sl parameter to index.php. NOTE: this can be leveraged for remote file execution by including adm.php and then invoking the upload action. NOTE: on 20080601, the vendor patched 3.1 without changing the version number.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2008-2650
- 2026-10-03 Alias added: GHSA-gh4f-5wmx-wwgh
References
Exploit 1
More Cmsimple vulnerabilities
- TI-2024-37939 CMSimple 5.16 allows the user to edit log.php file via print page. CVSS 3.1CRITICAL 9.1
- TI-2024-37940 CMSimple 5.16 allows the user to read cms source code through manipulation of the file… CVSS 3.1HIGH 7.5
- TI-2024-37938 Insecure Permissions vulnerability in CMSimple v.5.16 allows a remote attacker to obtain… CVSS 3.1HIGH 7.5
- TI-2024-37937 An issue in CMSimple v.5.16 allows a remote attacker to obtain sensitive information via… CVSS 3.1HIGH 7.5
- TI-2021-22352 CMSimple 5.4 Authenticated Remote Code Execution via Template Editing CVSS 4.0HIGH 8.6
- TI-2021-22351 CMSimple 5.4 Authenticated Local File Inclusion Remote Code Execution CVSS 4.0HIGH 8.6
Sources
- CVE-2008-2650 · CVE Program
- CVE-2008-2650 · NVD
- FIRST EPSS
- GHSA-gh4f-5wmx-wwgh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences