Vim 7.1.314, 6.4, and other versions allows user-assisted remote attackers to execute…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- —
- Confidentiality · integrity · availability
- Complete · Complete · Complete
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat.
Summary
Vim 7.1.314, 6.4, and other versions allows user-assisted remote attackers to execute arbitrary commands via Vim scripts that do not properly sanitize inputs before invoking the execute or system functions, as demonstrated using (1) filetype.vim, (3) xpm.vim, (4) gzip_vim, and (5) netrw. NOTE: the originally reported version was 7.1.314, but the researcher actually found this set of issues in 7.1.298. NOTE: the zipplugin issue (originally vector 2 in this identifier) has been subsumed by CVE-2008-3075.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* | up to 6.4; 7.0 – 7.1.314 | Vulnerable | vim |
| cpe:2.3:o:canonical:ubuntu_linux:6.06:*:*:*:lts:*:*:* | 6.06 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:7.10:*:*:*:*:*:*:* | 7.10 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:8.04:*:*:*:lts:*:*:* | 8.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:8.10:*:*:*:*:*:*:* | 8.10 | Vulnerable | Canonical |
- cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* Versions up to 6.4; 7.0 – 7.1.314 Vulnerable ·vim
- cpe:2.3:o:canonical:ubuntu_linux:6.06:*:*:*:lts:*:*:* Versions 6.06 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:7.10:*:*:*:*:*:*:* Versions 7.10 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:8.04:*:*:*:lts:*:*:* Versions 8.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:8.10:*:*:*:*:*:*:* Versions 8.10 Vulnerable ·Canonical
Remediation
Red Hat 3 advisories
- RHSA-2008:0618 Released 2008-11-25 · Red Hat rating Moderatevim security update
- Red Hat Enterprise Linux AS (Advanced Server) version 2.1 vim-1:6.0-7.25, vim-X11-1:6.0-7.25.i386, vim-X11-1:6.0-7.25.ia64 +6
- Red Hat Enterprise Linux ES version 2.1 vim-1:6.0-7.25, vim-X11-1:6.0-7.25.i386, vim-common-1:6.0-7.25.i386 +2
- Red Hat Enterprise Linux WS version 2.1 vim-1:6.0-7.25, vim-X11-1:6.0-7.25.i386, vim-common-1:6.0-7.25.i386 +2
- Red Hat Linux Advanced Workstation 2.1 vim-1:6.0-7.25, vim-X11-1:6.0-7.25.ia64, vim-common-1:6.0-7.25.ia64 +2
- RHSA-2008:0617 Released 2008-11-25 · Red Hat rating Moderatevim security update
- Red Hat Desktop version 3 vim-1:6.3.046-0.30E.11, vim-X11-1:6.3.046-0.30E.11, vim-X11-1:6.3.046-0.30E.11.i386 +6
- Red Hat Enterprise Linux AS version 3 vim-1:6.3.046-0.30E.11, vim-X11-1:6.3.046-0.30E.11, vim-X11-1:6.3.046-0.30E.11.i386 +14
- Red Hat Enterprise Linux AS version 4 vim-1:6.3.046-1.el4_7.5z, vim-X11-1:6.3.046-1.el4_7.5z, vim-X11-1:6.3.046-1.el4_7.5z.i386 +14
- Red Hat Enterprise Linux Desktop version 4 vim-1:6.3.046-1.el4_7.5z, vim-X11-1:6.3.046-1.el4_7.5z, vim-X11-1:6.3.046-1.el4_7.5z.i386 +6
- Red Hat Enterprise Linux ES version 3 vim-1:6.3.046-0.30E.11, vim-X11-1:6.3.046-0.30E.11, vim-X11-1:6.3.046-0.30E.11.i386 +10
- Red Hat Enterprise Linux ES version 4 vim-1:6.3.046-1.el4_7.5z, vim-X11-1:6.3.046-1.el4_7.5z, vim-X11-1:6.3.046-1.el4_7.5z.i386 +10
- Red Hat Enterprise Linux WS version 3 vim-1:6.3.046-0.30E.11, vim-X11-1:6.3.046-0.30E.11, vim-X11-1:6.3.046-0.30E.11.i386 +10
- Red Hat Enterprise Linux WS version 4 vim-1:6.3.046-1.el4_7.5z, vim-X11-1:6.3.046-1.el4_7.5z, vim-X11-1:6.3.046-1.el4_7.5z.i386 +10
- RHSA-2008:0580 Released 2008-11-25 · Red Hat rating Moderatevim security update
- Red Hat Enterprise Linux (v. 5 server) vim-2:7.0.109-4.el5_2.4z, vim-X11-2:7.0.109-4.el5_2.4z, vim-X11-2:7.0.109-4.el5_2.4z.i386 +14
- Red Hat Enterprise Linux Desktop (v. 5 client) vim-2:7.0.109-4.el5_2.4z, vim-X11-2:7.0.109-4.el5_2.4z, vim-X11-2:7.0.109-4.el5_2.4z.i386 +6
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Desktop version 3 | Fixed | RHSA-2008:0617 |
| Red Hat Enterprise Linux (v. 5 server) | Fixed | RHSA-2008:0580 |
| Red Hat Enterprise Linux AS (Advanced Server) version 2.1 | Fixed | RHSA-2008:0618 |
| Red Hat Enterprise Linux AS version 3 | Fixed | RHSA-2008:0617 |
| Red Hat Enterprise Linux AS version 4 | Fixed | RHSA-2008:0617 |
| Red Hat Enterprise Linux Desktop (v. 5 client) | Fixed | RHSA-2008:0580 |
| Red Hat Enterprise Linux Desktop version 4 | Fixed | RHSA-2008:0617 |
| Red Hat Enterprise Linux ES version 2.1 | Fixed | RHSA-2008:0618 |
| Red Hat Enterprise Linux ES version 3 | Fixed | RHSA-2008:0617 |
| Red Hat Enterprise Linux ES version 4 | Fixed | RHSA-2008:0617 |
| Red Hat Enterprise Linux WS version 2.1 | Fixed | RHSA-2008:0618 |
| Red Hat Enterprise Linux WS version 3 | Fixed | RHSA-2008:0617 |
| Red Hat Enterprise Linux WS version 4 | Fixed | RHSA-2008:0617 |
| Red Hat Linux Advanced Workstation 2.1 | Fixed | RHSA-2008:0618 |
Timeline
- 2026-10-02 Threatist record created from CVE-2008-2712
- 2026-10-03 Alias added: GHSA-j8hm-6qv5-gj2w
References
Advisory 24
- http://www.vmware.com/security/advisories/VMSA-2009-0004.html
- SUSE-SR:2009:007
- RHSA-2008:0618
- USN-712-1
- oval:org.mitre.oval:def:6238
- APPLE-SA-2010-03-29-1
- RHSA-2008:0580
- http://support.avaya.com/elmodocs2/security/ASA-2009-001.htm
- ADV-2009-0904
- ADV-2009-0033
- oval:org.mitre.oval:def:11109
- [oss-security] 20080616 CVE Id request: vim
- 20080701 Re: Collection of Vulnerabilities in Fully Patched Vim 7.1
- ADV-2008-1851
- http://support.avaya.com/elmodocs2/security/ASA-2008-457.htm
- http://support.apple.com/kb/HT4077
- 3951
- MDVSA-2008:236
- ADV-2008-2780
- [oss-security] 20081015 Vim CVE issues cleanup (plugins tar.vim, zip.vim) - CVE-2008-3074 and CVE-2008-3075
- APPLE-SA-2008-10-09
- http://support.apple.com/kb/HT3216
- http://wiki.rpath.com/Advisories:rPSA-2008-0247
- RHSA-2008:0617
Sources
- CVE-2008-2712 · CVE Program
- CVE-2008-2712 · NVD
- FIRST EPSS
- GHSA-j8hm-6qv5-gj2w · GitHub Advisory Database · CC BY 4.0
- CVE-2008-2712 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences