The Netrw plugin 125 in netrw.vim in Vim 7.2a.10 allows user-assisted attackers to…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Complete · Complete · Complete
- Fix status
- No fix listed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
The Netrw plugin 125 in netrw.vim in Vim 7.2a.10 allows user-assisted attackers to execute arbitrary code via shell metacharacters in filenames used by the execute and system functions within the (1) mz and (2) mc commands, as demonstrated by the netrw.v2 and netrw.v3 test cases. NOTE: this issue reportedly exists because of an incomplete fix for CVE-2008-2712.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2008-3076
- 2026-10-03 Alias added: GHSA-f5qf-9pc8-pr89
References
Exploit 5
- [oss-security] 20081016 CVE request - Vim netrw.plugin
- http://www.rdancer.org/vulnerablevim-netrw.html
- [oss-security] 20080707 Re: More arbitrary code executions in Netrw version 125, Vim 7.2a.10
- http://www.rdancer.org/vulnerablevim-netrw.v2.html
- [oss-security] 20080707 Re: More arbitrary code executions in Netrw version 125, Vim 7.2a.10
Other 5
- [oss-security] 20081020 CVE request (vim)
- http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0324
- 20080701 Re: Collection of Vulnerabilities in Fully Patched Vim 7.1
- [oss-security] 20080708 Re: More arbitrary code executions in Netrw version 125, Vim 7.2a.10
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=506919
More Vim vulnerabilities
- TI-2022-03248 Heap-based Buffer Overflow in vim/vim CVSS 3.1CRITICAL 9.8
- TI-2024-15103 Vim before 9.0.2142 has a stack-based buffer overflow because did_set_langmap in map.c… CVSS 3.1HIGH 7.8
- TI-2023-05093 Use After Free in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04407 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04379 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04378 Use After Free in vim/vim CVSS 3.1HIGH 7.8
Sources
- CVE-2008-3076 · CVE Program
- CVE-2008-3076 · NVD
- FIRST EPSS
- GHSA-f5qf-9pc8-pr89 · GitHub Advisory Database · CC BY 4.0
- CVE-2008-3076 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences