Multiple cross-site scripting (XSS) vulnerabilities in Drupal 6.x before 6.3 allow remote…
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in Drupal 6.x before 6.3 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) free tagging taxonomy terms, which are not properly handled on node preview pages, and (2) unspecified OpenID values.
Why it matters now
EPSS 0.02467 84th percentileScored 2026-11-07
Fix Fixed drupal/drupal (Packagist): 6.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | drupal/drupal (Packagist) | 6.0 to before 6.3 | 6.3 | Patch available | GHSA-6cj8-c359-p7q9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- drupal/drupal (Packagist) Vendor— Affected 6.0 to before 6.3 Fixed in 6.3 Patch available GHSA-6cj8-c359-p7q9
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 6.0 to before 6.3 | Vulnerable | Drupal |
| cpe:2.3:o:fedoraproject:fedora:8:*:*:*:*:*:*:* | 8 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:9:*:*:*:*:*:*:* | 9 | Vulnerable | Fedoraproject |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 6.0 to before 6.3 Vulnerable ·Drupal
- cpe:2.3:o:fedoraproject:fedora:8:*:*:*:*:*:*:* Versions 8 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:9:*:*:*:*:*:*:* Versions 9 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-6cj8-c359-p7q9 drupal/drupal (Packagist) Fixed in 6.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2008-3218
- 2026-10-03 Alias added: GHSA-6cj8-c359-p7q9
References
Advisory 6
Sources
- CVE-2008-3218 · CVE Program
- CVE-2008-3218 · NVD
- FIRST EPSS
- GHSA-6cj8-c359-p7q9 · GitHub Advisory Database · CC BY 4.0
- CVE-2008-3218 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences