Joomla! before 1.5.4 does not configure .htaccess to apply certain security checks that…
Priority LOW 35CWE-16Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
Joomla! before 1.5.4 does not configure .htaccess to apply certain security checks that "block common exploits" to SEF URLs, which has unknown impact and remote attack vectors.
Why it matters now
EPSS 0.01164 67th percentileScored 2026-11-07
Fix Fixed joomla/joomla-platform (Packagist): 1.5.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | joomla/joomla-platform (Packagist) | before 1.5.4 | 1.5.4 | Patch available | GHSA-mxr8-pcpg-m23j |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- joomla/joomla-platform (Packagist) Vendor— Affected before 1.5.4 Fixed in 1.5.4 Patch available GHSA-mxr8-pcpg-m23j
CPE configurations NVD · 24
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:joomla:joomla:*:*:*:*:*:*:*:* | up to 1.5.3 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.0:*:*:*:*:*:*:* | 1.0 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.0.0:*:*:*:*:*:*:* | 1.0.0 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.0.1:*:*:*:*:*:*:* | 1.0.1 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.0.2:*:*:*:*:*:*:* | 1.0.2 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.0.3:*:*:*:*:*:*:* | 1.0.3 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.0.4:*:*:*:*:*:*:* | 1.0.4 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.0.5:*:*:*:*:*:*:* | 1.0.5 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.0.6:*:*:*:*:*:*:* | 1.0.6 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.0.7:*:*:*:*:*:*:* | 1.0.7 | Vulnerable | Joomla! |
- cpe:2.3:a:joomla:joomla:*:*:*:*:*:*:*:* Versions up to 1.5.3 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.0:*:*:*:*:*:*:* Versions 1.0 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.0.1:*:*:*:*:*:*:* Versions 1.0.1 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.0.2:*:*:*:*:*:*:* Versions 1.0.2 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.0.3:*:*:*:*:*:*:* Versions 1.0.3 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.0.4:*:*:*:*:*:*:* Versions 1.0.4 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.0.5:*:*:*:*:*:*:* Versions 1.0.5 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.0.6:*:*:*:*:*:*:* Versions 1.0.6 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.0.7:*:*:*:*:*:*:* Versions 1.0.7 Vulnerable ·Joomla!
Show 14 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:joomla:joomla:1.0.8:*:*:*:*:*:*:* | 1.0.8 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.0.9:*:*:*:*:*:*:* | 1.0.9 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.0.10:*:*:*:*:*:*:* | 1.0.10 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.0.11:*:*:*:*:*:*:* | 1.0.11 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.0.12:*:*:*:*:*:*:* | 1.0.12 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.0.13:*:*:*:*:*:*:* | 1.0.13 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.03:*:*:*:*:*:*:* | 1.03 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.5:*:*:*:*:*:*:* | 1.5 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.5.0_beta:*:*:*:*:*:*:* | 1.5.0_beta | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.5.0_beta1:*:*:*:*:*:*:* | 1.5.0_beta1 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.5.0_beta2:*:*:*:*:*:*:* | 1.5.0_beta2 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.5.0_rc1:*:*:*:*:*:*:* | 1.5.0_rc1 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.5.1:*:*:*:*:*:*:* | 1.5.1 | Vulnerable | Joomla! |
| cpe:2.3:a:joomla:joomla:1.5.2:*:*:*:*:*:*:* | 1.5.2 | Vulnerable | Joomla! |
- cpe:2.3:a:joomla:joomla:1.0.8:*:*:*:*:*:*:* Versions 1.0.8 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.0.9:*:*:*:*:*:*:* Versions 1.0.9 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.0.10:*:*:*:*:*:*:* Versions 1.0.10 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.0.11:*:*:*:*:*:*:* Versions 1.0.11 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.0.12:*:*:*:*:*:*:* Versions 1.0.12 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.0.13:*:*:*:*:*:*:* Versions 1.0.13 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.03:*:*:*:*:*:*:* Versions 1.03 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.5:*:*:*:*:*:*:* Versions 1.5 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.5.0_beta:*:*:*:*:*:*:* Versions 1.5.0_beta Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.5.0_beta1:*:*:*:*:*:*:* Versions 1.5.0_beta1 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.5.0_beta2:*:*:*:*:*:*:* Versions 1.5.0_beta2 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.5.0_rc1:*:*:*:*:*:*:* Versions 1.5.0_rc1 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.5.1:*:*:*:*:*:*:* Versions 1.5.1 Vulnerable ·Joomla!
- cpe:2.3:a:joomla:joomla:1.5.2:*:*:*:*:*:*:* Versions 1.5.2 Vulnerable ·Joomla!
Remediation
- Fix · GHSA-mxr8-pcpg-m23j joomla/joomla-platform (Packagist) Fixed in 1.5.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2008-3228
- 2026-10-03 Alias added: GHSA-mxr8-pcpg-m23j
References
More Joomla! Joomla vulnerabilities
- TI-2007-04882 PHP remote file inclusion vulnerability in admin.slideshow1.php in the Flash Slide Show… CVSS 2.0HIGH 7.5
- TI-2007-02120 PHP remote file inclusion vulnerability in lib/pcltar.lib.php (aka pcltar.php) in the… CVSS 2.0MEDIUM 6.8
- TI-2007-05243 Multiple PHP remote file inclusion vulnerabilities in Michael Dempfle Joomla Flash… CVSS 2.0MEDIUM 6.8
- TI-2007-05150 Multiple PHP remote file inclusion vulnerabilities in the Avant-Garde Solutions MOSMedia… CVSS 2.0MEDIUM 6.8
- TI-2007-05237 PHP remote file inclusion vulnerability in admin.color.php in the com_colorlab (aka… CVSS 2.0MEDIUM 6.8
- TI-2007-05151 PHP remote file inclusion vulnerability in admin.panoramic.php in the Panoramic Picture… CVSS 2.0MEDIUM 6.8
Sources
- CVE-2008-3228 · CVE Program
- CVE-2008-3228 · NVD
- FIRST EPSS
- GHSA-mxr8-pcpg-m23j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences