The administration application in Django 0.91, 0.95, and 0.96 stores unauthenticated HTTP…
Priority LOW 28CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
The administration application in Django 0.91, 0.95, and 0.96 stores unauthenticated HTTP POST requests and processes them after successful authentication occurs, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks and delete or modify data via unspecified requests.
Why it matters now
EPSS 0.00923 60th percentileScored 2026-11-07
Fix Fixed Django (PyPI): 0.91.3, 0.95.4, 0.96.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | 0.91.0 to before 0.91.3 | 0.91.3 | Patch available | GHSA-r5cj-wv24-92p5 |
| — | Django (PyPI) | 0.95.0 to before 0.95.4 | 0.95.4 | Patch available | GHSA-r5cj-wv24-92p5 |
| — | Django (PyPI) | 0.96.0 to before 0.96.3 | 0.96.3 | Patch available | GHSA-r5cj-wv24-92p5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected 0.91.0 to before 0.91.3 Fixed in 0.91.3 Patch available GHSA-r5cj-wv24-92p5
- Django (PyPI) Vendor— Affected 0.95.0 to before 0.95.4 Fixed in 0.95.4 Patch available GHSA-r5cj-wv24-92p5
- Django (PyPI) Vendor— Affected 0.96.0 to before 0.96.3 Fixed in 0.96.3 Patch available GHSA-r5cj-wv24-92p5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | 0.91 to before 0.91.3; 0.95 to before 0.95.4; 0.96 to before 0.96.3 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 0.91 to before 0.91.3; 0.95 to before 0.95.4; 0.96 to before 0.96.3 Vulnerable ·djangoproject
Remediation
- Fix · GHSA-r5cj-wv24-92p5 Django (PyPI) Fixed in 0.91.3 Advisory →
- Fix · GHSA-r5cj-wv24-92p5 Django (PyPI) Fixed in 0.95.4 Advisory →
- Fix · GHSA-r5cj-wv24-92p5 Django (PyPI) Fixed in 0.96.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2008-3909
- 2026-10-03 Alias added: GHSA-r5cj-wv24-92p5
References
Advisory 6
Other 8
- ADV-2008-2533
- 47906
- https://github.com/django/django/commit/44debfeaa4473bd28872c735dd3d9afde6886752
- https://github.com/django/django/commit/7e0972bded362bc4b851c109df2c8a6548481a8e
- https://github.com/django/django/commit/aee48854a164382c655acb9f18b3c06c3d238e81
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2008-2.yaml
- http://www.djangoproject.com/weblog/2008/sep/02/security
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2008-3909 · CVE Program
- CVE-2008-3909 · NVD
- FIRST EPSS
- GHSA-r5cj-wv24-92p5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences