Cross-site scripting (XSS) vulnerability in the command-line client in MySQL 5.0.26…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the command-line client in MySQL 5.0.26 through 5.0.45, and other versions including versions later than 5.0.45, when the --html option is enabled, allows attackers to inject arbitrary web script or HTML by placing it in a database cell, which might be accessed by this client when composing an HTML document. NOTE: as of 20081031, the issue has not been fixed in MySQL 5.0.67.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mysql:mysql:5.0.4:*:*:*:*:*:*:* | 5.0.4 | Vulnerable | Mysql |
| cpe:2.3:a:mysql:mysql:5.0.30:*:*:*:*:*:*:* | 5.0.30 | Vulnerable | Mysql |
| cpe:2.3:a:mysql:mysql:5.0.36:*:*:*:*:*:*:* | 5.0.36 | Vulnerable | Mysql |
| cpe:2.3:a:mysql:mysql:5.0.44:*:*:*:*:*:*:* | 5.0.44 | Vulnerable | Mysql |
| cpe:2.3:a:oracle:mysql:5.0.26:*:*:*:*:*:*:* | 5.0.26 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:mysql:5.0.27:*:*:*:*:*:*:* | 5.0.27 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:mysql:5.0.30:sp1:*:*:*:*:*:* | 5.0.30 sp1 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:mysql:5.0.32:*:*:*:*:*:*:* | 5.0.32 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:mysql:5.0.33:*:*:*:*:*:*:* | 5.0.33 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:mysql:5.0.37:*:*:*:*:*:*:* | 5.0.37 | Vulnerable | Oracle |
- cpe:2.3:a:mysql:mysql:5.0.4:*:*:*:*:*:*:* Versions 5.0.4 Vulnerable ·Mysql
- cpe:2.3:a:mysql:mysql:5.0.30:*:*:*:*:*:*:* Versions 5.0.30 Vulnerable ·Mysql
- cpe:2.3:a:mysql:mysql:5.0.36:*:*:*:*:*:*:* Versions 5.0.36 Vulnerable ·Mysql
- cpe:2.3:a:mysql:mysql:5.0.44:*:*:*:*:*:*:* Versions 5.0.44 Vulnerable ·Mysql
- cpe:2.3:a:oracle:mysql:5.0.26:*:*:*:*:*:*:* Versions 5.0.26 Vulnerable ·Oracle
- cpe:2.3:a:oracle:mysql:5.0.27:*:*:*:*:*:*:* Versions 5.0.27 Vulnerable ·Oracle
- cpe:2.3:a:oracle:mysql:5.0.30:sp1:*:*:*:*:*:* Versions 5.0.30 sp1 Vulnerable ·Oracle
- cpe:2.3:a:oracle:mysql:5.0.32:*:*:*:*:*:*:* Versions 5.0.32 Vulnerable ·Oracle
- cpe:2.3:a:oracle:mysql:5.0.33:*:*:*:*:*:*:* Versions 5.0.33 Vulnerable ·Oracle
- cpe:2.3:a:oracle:mysql:5.0.37:*:*:*:*:*:*:* Versions 5.0.37 Vulnerable ·Oracle
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:oracle:mysql:5.0.38:*:*:*:*:*:*:* | 5.0.38 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:mysql:5.0.41:*:*:*:*:*:*:* | 5.0.41 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:mysql:5.0.42:*:*:*:*:*:*:* | 5.0.42 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:mysql:5.0.45:*:*:*:*:*:*:* | 5.0.45 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:mysql:5.0.67:*:*:*:*:*:*:* | 5.0.67 | Vulnerable | Oracle |
- cpe:2.3:a:oracle:mysql:5.0.38:*:*:*:*:*:*:* Versions 5.0.38 Vulnerable ·Oracle
- cpe:2.3:a:oracle:mysql:5.0.41:*:*:*:*:*:*:* Versions 5.0.41 Vulnerable ·Oracle
- cpe:2.3:a:oracle:mysql:5.0.42:*:*:*:*:*:*:* Versions 5.0.42 Vulnerable ·Oracle
- cpe:2.3:a:oracle:mysql:5.0.45:*:*:*:*:*:*:* Versions 5.0.45 Vulnerable ·Oracle
- cpe:2.3:a:oracle:mysql:5.0.67:*:*:*:*:*:*:* Versions 5.0.67 Vulnerable ·Oracle
Remediation
Red Hat 3 advisories
- RHSA-2010:0110 Released 2010-02-16 · Red Hat rating Moderatemysql security update
- Red Hat Enterprise Linux AS version 4 mysql-4.1.22-2.el4_8.3, mysql-4.1.22-2.el4_8.3.i386, mysql-4.1.22-2.el4_8.3.ia64 +13
- Red Hat Enterprise Linux Desktop version 4 mysql-4.1.22-2.el4_8.3, mysql-4.1.22-2.el4_8.3.i386, mysql-bench-4.1.22-2.el4_8.3 +5
- Red Hat Enterprise Linux ES version 4 mysql-4.1.22-2.el4_8.3, mysql-4.1.22-2.el4_8.3.i386, mysql-4.1.22-2.el4_8.3.ia64 +9
- Red Hat Enterprise Linux WS version 4 mysql-4.1.22-2.el4_8.3, mysql-4.1.22-2.el4_8.3.i386, mysql-4.1.22-2.el4_8.3.ia64 +9
- RHSA-2009:1461 Released 2009-09-23 · Red Hat rating ImportantRed Hat Application Stack v2.4 security and enhancement update
- Red Hat Application Stack v2 for Enterprise Linux (v.5) httpd-2.2.13-2.el5s2, httpd-2.2.13-2.el5s2.i386, httpd-devel-2.2.13-2.el5s2 +47
- RHSA-2009:1289 Released 2009-09-02 · Red Hat rating Moderatemysql security and bug fix update
- Red Hat Enterprise Linux (v. 5 server) mysql-5.0.77-3.el5, mysql-5.0.77-3.el5.i386, mysql-5.0.77-3.el5.ia64 +17
- Red Hat Enterprise Linux Desktop (v. 5 client) mysql-5.0.77-3.el5, mysql-5.0.77-3.el5.i386
- Red Hat Enterprise Linux Desktop Workstation (v. 5 client) mysql-5.0.77-3.el5, mysql-bench-5.0.77-3.el5, mysql-bench-5.0.77-3.el5.i386 +6
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux (v. 5 server) | Fixed | RHSA-2009:1289 |
| Red Hat Enterprise Linux AS version 4 | Fixed | RHSA-2010:0110 |
| Red Hat Enterprise Linux Desktop (v. 5 client) | Fixed | RHSA-2009:1289 |
| Red Hat Enterprise Linux Desktop Workstation (v. 5 client) | Fixed | RHSA-2009:1289 |
| Red Hat Enterprise Linux Desktop version 4 | Fixed | RHSA-2010:0110 |
| Red Hat Enterprise Linux ES version 4 | Fixed | RHSA-2010:0110 |
| Red Hat Enterprise Linux WS version 4 | Fixed | RHSA-2010:0110 |
Timeline
- 2026-10-02 Threatist record created from CVE-2008-4456
- 2026-10-03 Alias added: GHSA-wwgr-xr73-wm3j
References
Advisory 8
Sources
- CVE-2008-4456 · CVE Program
- CVE-2008-4456 · NVD
- FIRST EPSS
- GHSA-wwgr-xr73-wm3j · GitHub Advisory Database · CC BY 4.0
- CVE-2008-4456 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences