Read the docs
TI-2008-06936 Aliases CVE-2008-7248GHSA-8fqx-7pv4-3jwm

Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests…

Priority MEDIUM 41CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
—
Confidentiality · integrity · availability
Partial · Partial · Partial
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.

Summary

Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote attackers to bypass cross-site request forgery (CSRF) protection for requests to applications that rely on this protection, as demonstrated using text/plain.

Why it matters now

EPSS 0.0808 94th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed actionpack (RubyGems): 2.1.3, 2.2.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—actionpack (RubyGems)2.1.0 to before 2.1.32.1.3Patch availableGHSA-8fqx-7pv4-3jwm
—actionpack (RubyGems)2.2.0 to before 2.2.22.2.2Patch availableGHSA-8fqx-7pv4-3jwm
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • actionpack (RubyGems) Vendor— Affected 2.1.0 to before 2.1.3 Fixed in 2.1.3 Patch available GHSA-8fqx-7pv4-3jwm
  • actionpack (RubyGems) Vendor— Affected 2.2.0 to before 2.2.2 Fixed in 2.2.2 Patch available GHSA-8fqx-7pv4-3jwm

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:rubyonrails:rails:2.1.0:*:*:*:*:*:*:*2.1.0VulnerableRails
cpe:2.3:a:rubyonrails:rails:2.1.1:*:*:*:*:*:*:*2.1.1VulnerableRails
cpe:2.3:a:rubyonrails:rails:2.1.2:*:*:*:*:*:*:*2.1.2VulnerableRails
cpe:2.3:a:rubyonrails:rails:2.2.0:*:*:*:*:*:*:*2.2.0VulnerableRails
cpe:2.3:a:rubyonrails:rails:2.2.1:*:*:*:*:*:*:*2.2.1VulnerableRails
  • cpe:2.3:a:rubyonrails:rails:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Rails
  • cpe:2.3:a:rubyonrails:rails:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Rails
  • cpe:2.3:a:rubyonrails:rails:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·Rails
  • cpe:2.3:a:rubyonrails:rails:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Rails
  • cpe:2.3:a:rubyonrails:rails:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·Rails

Remediation

  • Fix · GHSA-8fqx-7pv4-3jwm actionpack (RubyGems) Fixed in 2.1.3 Advisory →
  • Fix · GHSA-8fqx-7pv4-3jwm actionpack (RubyGems) Fixed in 2.2.2 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2008-7248
  2. 2026-10-03 Alias added: GHSA-8fqx-7pv4-3jwm

References

  • TI-2014-00124 Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the… KEVCVSS 3.1HIGH 7.5
  • TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
  • TI-2016-00672 Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x… KEVCVSS 3.1HIGH 7.5
  • TI-2019-03830 Command injection in Rails https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
  • TI-2020-06581 Code injection in https://github.com/rails/rails CVSS 3.1HIGH 8.8
  • TI-2013-00091 active_support/core_ext/hash/conversions.rb in Ruby on Rails before 2.3.15, 3.0.x before… CVSS 2.0HIGH 7.5
See all 117 →

Sources