Multiple cross-site request forgery (CSRF) vulnerabilities in the web administration…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Tampering
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Multiple cross-site request forgery (CSRF) vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 allow remote attackers to hijack the authentication of administrators for requests that (1) change the web administration password, (2) upload applications, and perform unspecified other administrative actions, as demonstrated by (3) a Shutdown request to console/portal//Server/Shutdown.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.geronimo.plugins:console (Maven) | before 2.1.4 | 2.1.4 | Patch available | GHSA-678x-xfp4-r92r |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.geronimo.plugins:console (Maven) Vendor— Affected before 2.1.4 Fixed in 2.1.4 Patch available GHSA-678x-xfp4-r92r
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:geronimo:2.1:*:*:*:*:*:*:* | 2.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:geronimo:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:geronimo:2.1.2:*:*:*:*:*:*:* | 2.1.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:geronimo:2.1.3:*:*:*:*:*:*:* | 2.1.3 | Vulnerable | Apache |
- cpe:2.3:a:apache:geronimo:2.1:*:*:*:*:*:*:* Versions 2.1 Vulnerable ·Apache
- cpe:2.3:a:apache:geronimo:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:geronimo:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·Apache
- cpe:2.3:a:apache:geronimo:2.1.3:*:*:*:*:*:*:* Versions 2.1.3 Vulnerable ·Apache
Remediation
- Fix · GHSA-678x-xfp4-r92r org.apache.geronimo.plugins:console (Maven) Fixed in 2.1.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2009-0039
- 2026-10-03 Alias added: GHSA-678x-xfp4-r92r
References
Advisory 3
More Apache Geronimo vulnerabilities
- TI-2011-04311 Apache Geronimo 2.2.1 and earlier computes hash values for form parameters without… CVSS 2.0HIGH 7.8
- TI-2008-05234 Multiple directory traversal vulnerabilities in the web administration console in Apache… CVSS 2.0HIGH 9.4
- TI-2013-01564 The JMX Remoting functionality in Apache Geronimo 3.x before 3.0.1, as used in IBM… CVSS 2.0HIGH 10.0
- TI-2007-04403 The login method in LoginModule implementations in Apache Geronimo 2.0 does not throw… CVSS 2.0HIGH 10.0
- TI-2006-00245 Multiple cross-site scripting (XSS) vulnerabilities in Apache Geronimo 1.0 allow remote… CVSS 2.0MEDIUM 4.3
- TI-2007-05563 SQLLoginModule in Apache Geronimo 2.0 through 2.1 does not throw an exception for a… CVSS 2.0HIGH 7.5
Sources
- CVE-2009-0039 · CVE Program
- CVE-2009-0039 · NVD
- FIRST EPSS
- GHSA-678x-xfp4-r92r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences