Read the docs
TI-2009-02093 Aliases CVE-2009-2186GHSA-v9mm-j6r3-xv8r

Unspecified vulnerability in Adobe Shockwave Player before 11.0.0.465 allows remote…

Priority MEDIUM 48Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
—
Confidentiality · integrity · availability
Complete · Complete · Complete
Fix status
No fix listed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA.

Summary

Unspecified vulnerability in Adobe Shockwave Player before 11.0.0.465 allows remote attackers to execute arbitrary code via unknown vectors, a different vulnerability than CVE-2009-1860, related to an older issue that "was previously resolved in Shockwave Player 11.0.0.465."

Why it matters now

EPSS 0.04722 91st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 11

CPEVersionsRoleVendor
cpe:2.3:a:adobe:shockwave_player:*:*:*:*:*:*:*:*up to 11.0.0.456VulnerableAdobe
cpe:2.3:a:adobe:shockwave_player:1.0:*:*:*:*:*:*:*1.0VulnerableAdobe
cpe:2.3:a:adobe:shockwave_player:2.0:*:*:*:*:*:*:*2.0VulnerableAdobe
cpe:2.3:a:adobe:shockwave_player:3.0:*:*:*:*:*:*:*3.0VulnerableAdobe
cpe:2.3:a:adobe:shockwave_player:4.0:*:*:*:*:*:*:*4.0VulnerableAdobe
cpe:2.3:a:adobe:shockwave_player:5.0:*:*:*:*:*:*:*5.0VulnerableAdobe
cpe:2.3:a:adobe:shockwave_player:6.0:*:*:*:*:*:*:*6.0VulnerableAdobe
cpe:2.3:a:adobe:shockwave_player:8.0:*:*:*:*:*:*:*8.0VulnerableAdobe
cpe:2.3:a:adobe:shockwave_player:8.5.1:*:*:*:*:*:*:*8.5.1VulnerableAdobe
cpe:2.3:a:adobe:shockwave_player:9:*:*:*:*:*:*:*9VulnerableAdobe
  • cpe:2.3:a:adobe:shockwave_player:*:*:*:*:*:*:*:* Versions up to 11.0.0.456 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:shockwave_player:1.0:*:*:*:*:*:*:* Versions 1.0 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:shockwave_player:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:shockwave_player:3.0:*:*:*:*:*:*:* Versions 3.0 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:shockwave_player:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:shockwave_player:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:shockwave_player:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:shockwave_player:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:shockwave_player:8.5.1:*:*:*:*:*:*:* Versions 8.5.1 Vulnerable ·Adobe
  • cpe:2.3:a:adobe:shockwave_player:9:*:*:*:*:*:*:* Versions 9 Vulnerable ·Adobe
Show 1 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:adobe:shockwave_player:10.1.0.11:*:*:*:*:*:*:*10.1.0.11VulnerableAdobe
  • cpe:2.3:a:adobe:shockwave_player:10.1.0.11:*:*:*:*:*:*:* Versions 10.1.0.11 Vulnerable ·Adobe

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2009-2186
  2. 2026-10-03 Alias added: GHSA-v9mm-j6r3-xv8r

References

  • TI-2010-03478 The Director module (dirapi.dll) in Adobe Shockwave Player before 11.5.9.615 allows… CVSS 2.0HIGH 9.3
  • TI-2007-05680 Stack-based buffer overflow in the SWCtl.SWCtl ActiveX control in Adobe Shockwave allows… CVSS 2.0HIGH 10.0
  • TI-2012-01804 Adobe Shockwave Player before 11.6.5.635 allows attackers to execute arbitrary code or… CVSS 2.0HIGH 10.0
  • TI-2009-03088 Heap-based buffer overflow in the SwDir.dll ActiveX control in Adobe Shockwave Player… CVSS 2.0HIGH 9.3
  • TI-2005-03348 Stack-based buffer overflow in an ActiveX control for the installer for Adobe Macromedia… CVSS 2.0HIGH 9.3
  • TI-2013-00529 Stack-based buffer overflow in Adobe Shockwave Player before 12.0.0.112 allows attackers… CVSS 2.0HIGH 10.0
See all 173 →

Sources