Read the docs
TI-2009-02801 Aliases CVE-2009-2940GHSA-xv6x-43gq-4hfj

The pygresql module 3.8.1 and 4.0 for Python does not properly support the…

Priority LOW 38CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
Partial · Partial · Partial
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-89.

Summary

The pygresql module 3.8.1 and 4.0 for Python does not properly support the PQescapeStringConn function, which might allow remote attackers to leverage escaping issues involving multibyte character encodings.

Why it matters now

EPSS 0.02702 86th percentileScored 2026-11-07
Fix Partial PyGreSQL (PyPI): 4.1Red Hat: 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—PyGreSQL (PyPI)up to 3.8.1—No fix listedGHSA-xv6x-43gq-4hfj
—PyGreSQL (PyPI)4.0 to before 4.14.1Patch availableGHSA-xv6x-43gq-4hfj
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • PyGreSQL (PyPI) Vendor— Affected up to 3.8.1 Fixed in — No fix listed GHSA-xv6x-43gq-4hfj
  • PyGreSQL (PyPI) Vendor— Affected 4.0 to before 4.1 Fixed in 4.1 Patch available GHSA-xv6x-43gq-4hfj

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:pygresql:pygresql:3.8.1:*:*:*:*:*:*:*3.8.1VulnerablePygresql
cpe:2.3:a:pygresql:pygresql:4.0:*:*:*:*:*:*:*4.0VulnerablePygresql
cpe:2.3:a:python:python:*:*:*:*:*:*:*:*all versionsRunning onpython-pillow
  • cpe:2.3:a:pygresql:pygresql:3.8.1:*:*:*:*:*:*:* Versions 3.8.1 Vulnerable ·Pygresql
  • cpe:2.3:a:pygresql:pygresql:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·Pygresql
  • cpe:2.3:a:python:python:*:*:*:*:*:*:*:* Versions all versions Running on ·python-pillow

Remediation

  • Fix · GHSA-xv6x-43gq-4hfj PyGreSQL (PyPI) Fixed in 4.1 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Will not fix
Not affected: 1 product
  • Red Hat Enterprise Linux 7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2009-2940
  2. 2026-10-03 Alias added: GHSA-xv6x-43gq-4hfj

References

Sources