Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x…
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.
Why it matters now
EPSS 0.03022 87th percentileScored 2026-11-07
Fix Fixed actionpack (RubyGems): 2.2.3, 2.3.4activesupport (RubyGems): 2.2.3, 2.3.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | actionpack (RubyGems) | 2.0.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-8qrh-h9m2-5fvf |
| — | actionpack (RubyGems) | 2.3.0 to before 2.3.4 | 2.3.4 | Patch available | GHSA-8qrh-h9m2-5fvf |
| — | activesupport (RubyGems) | 2.0.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-8qrh-h9m2-5fvf |
| — | activesupport (RubyGems) | 2.3.0 to before 2.3.4 | 2.3.4 | Patch available | GHSA-8qrh-h9m2-5fvf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- actionpack (RubyGems) Vendor— Affected 2.0.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-8qrh-h9m2-5fvf
- actionpack (RubyGems) Vendor— Affected 2.3.0 to before 2.3.4 Fixed in 2.3.4 Patch available GHSA-8qrh-h9m2-5fvf
- activesupport (RubyGems) Vendor— Affected 2.0.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-8qrh-h9m2-5fvf
- activesupport (RubyGems) Vendor— Affected 2.3.0 to before 2.3.4 Fixed in 2.3.4 Patch available GHSA-8qrh-h9m2-5fvf
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyonrails:rails:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.0.0:rc1:*:*:*:*:*:* | 2.0.0 rc1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.0.0:rc2:*:*:*:*:*:* | 2.0.0 rc2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.0.2:*:*:*:*:*:*:* | 2.0.2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.0.4:*:*:*:*:*:*:* | 2.0.4 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.1.2:*:*:*:*:*:*:* | 2.1.2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | Rails |
- cpe:2.3:a:rubyonrails:rails:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.0.0:rc1:*:*:*:*:*:* Versions 2.0.0 rc1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.0.0:rc2:*:*:*:*:*:* Versions 2.0.0 rc2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.0.4:*:*:*:*:*:*:* Versions 2.0.4 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Rails
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyonrails:rails:2.2.1:*:*:*:*:*:*:* | 2.2.1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.2.2:*:*:*:*:*:*:* | 2.2.2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.3.2:*:*:*:*:*:*:* | 2.3.2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.3.3:*:*:*:*:*:*:* | 2.3.3 | Vulnerable | Rails |
- cpe:2.3:a:rubyonrails:rails:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.2.2:*:*:*:*:*:*:* Versions 2.2.2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.3.2:*:*:*:*:*:*:* Versions 2.3.2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.3.3:*:*:*:*:*:*:* Versions 2.3.3 Vulnerable ·Rails
Remediation
- Fix · GHSA-8qrh-h9m2-5fvf actionpack (RubyGems) Fixed in 2.2.3 Advisory →
- Fix · GHSA-8qrh-h9m2-5fvf actionpack (RubyGems) Fixed in 2.3.4 Advisory →
- Fix · GHSA-8qrh-h9m2-5fvf activesupport (RubyGems) Fixed in 2.2.3 Advisory →
- Fix · GHSA-8qrh-h9m2-5fvf activesupport (RubyGems) Fixed in 2.3.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2009-3009
- 2026-10-03 Alias added: GHSA-8qrh-h9m2-5fvf
References
Advisory 5
More Rails vulnerabilities
- TI-2014-00124 Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the… KEVCVSS 3.1HIGH 7.5
- TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
- TI-2016-00672 Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x… KEVCVSS 3.1HIGH 7.5
- TI-2019-03830 Command injection in Rails https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
- TI-2020-06581 Code injection in https://github.com/rails/rails CVSS 3.1HIGH 8.8
- TI-2013-00091 active_support/core_ext/hash/conversions.rb in Ruby on Rails before 2.3.15, 3.0.x before… CVSS 2.0HIGH 7.5
Sources
- CVE-2009-3009 · CVE Program
- CVE-2009-3009 · NVD
- FIRST EPSS
- GHSA-8qrh-h9m2-5fvf · GitHub Advisory Database · CC BY 4.0
- CVE-2009-3009 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences