Algorithmic complexity vulnerability in the forms library in Django 1.0 before 1.0.4 and…
Priority LOW 29CWE-1333Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-1333.
Summary
Algorithmic complexity vulnerability in the forms library in Django 1.0 before 1.0.4 and 1.1 before 1.1.1 allows remote attackers to cause a denial of service (CPU consumption) via a crafted (1) EmailField (email address) or (2) URLField (URL) that triggers a large amount of backtracking in a regular expression.
Why it matters now
EPSS 0.03789 90th percentileScored 2026-11-07
Fix Fixed Django (PyPI): 1.0.4, 1.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | 1.0 to before 1.0.4 | 1.0.4 | Patch available | GHSA-p6m5-h7pp-v2x5 |
| — | Django (PyPI) | 1.1 to before 1.1.1 | 1.1.1 | Patch available | GHSA-p6m5-h7pp-v2x5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected 1.0 to before 1.0.4 Fixed in 1.0.4 Patch available GHSA-p6m5-h7pp-v2x5
- Django (PyPI) Vendor— Affected 1.1 to before 1.1.1 Fixed in 1.1.1 Patch available GHSA-p6m5-h7pp-v2x5
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:1.0:*:*:*:*:*:*:* | 1.0 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.1:*:*:*:*:*:*:* | 1.1 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:1.0:*:*:*:*:*:*:* Versions 1.0 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.1:*:*:*:*:*:*:* Versions 1.1 Vulnerable ·djangoproject
Remediation
- Fix · GHSA-p6m5-h7pp-v2x5 Django (PyPI) Fixed in 1.0.4 Advisory →
- Fix · GHSA-p6m5-h7pp-v2x5 Django (PyPI) Fixed in 1.1.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2009-3695
- 2026-10-03 Alias added: GHSA-p6m5-h7pp-v2x5
- 2026-11-06 EPSS moved to the 90th–95th percentile
References
Other 12
- http://groups.google.com/group/django-users/browse_thread/thread/15df9e45118dfc51/
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=550457
- [oss-security] 20091013 Re: Duplicate CVE assignment notification [was: CVE id request: django]
- https://github.com/django/django/commit/594a28a9044120bed58671dde8a805c9e0f6c79a
- https://github.com/django/django/commit/e3e992e18b368fcd56aabafc1b5bf80a6e11b495
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2009-4.yaml
- https://web.archive.org/web/20091013093057/http://secunia.com/advisories/36968
- https://web.archive.org/web/20091017070244/http://secunia.com/advisories/36948
- https://web.archive.org/web/20200228171918/http://www.securityfocus.com/bid/36655
- http://groups.google.com/group/django-users/browse_thread/thread/15df9e45118dfc51
- http://www.djangoproject.com/weblog/2009/oct/09/security
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2009-3695 · CVE Program
- CVE-2009-3695 · NVD
- FIRST EPSS
- GHSA-p6m5-h7pp-v2x5 · GitHub Advisory Database · CC BY 4.0
- CVE-2009-3695 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences