Cross-site scripting (XSS) vulnerability in the Commerce extension before 0.9.9 for TYPO3…
Priority LOW 18CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the Commerce extension before 0.9.9 for TYPO3 allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.
Why it matters now
EPSS 0.00833 57th percentileScored 2026-11-07
Fix Fixed commerceteam/commerce (Packagist): 0.9.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | commerceteam/commerce (Packagist) | 0.9.6 to before 0.9.9 | 0.9.9 | Patch available | GHSA-rmc9-5546-5rrf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- commerceteam/commerce (Packagist) Vendor— Affected 0.9.6 to before 0.9.9 Fixed in 0.9.9 Patch available GHSA-rmc9-5546-5rrf
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:typo3:commerce_extension:*:*:*:*:*:*:*:* | up to 0.9.8 | Vulnerable | TYPO3 |
| cpe:2.3:a:typo3:commerce_extension:0.8.32:*:*:*:*:*:*:* | 0.8.32 | Vulnerable | TYPO3 |
| cpe:2.3:a:typo3:commerce_extension:0.8.35:*:*:*:*:*:*:* | 0.8.35 | Vulnerable | TYPO3 |
| cpe:2.3:a:typo3:commerce_extension:0.9.0:*:*:*:*:*:*:* | 0.9.0 | Vulnerable | TYPO3 |
| cpe:2.3:a:typo3:commerce_extension:0.9.5:*:*:*:*:*:*:* | 0.9.5 | Vulnerable | TYPO3 |
| cpe:2.3:a:typo3:commerce_extension:0.9.6:*:*:*:*:*:*:* | 0.9.6 | Vulnerable | TYPO3 |
| cpe:2.3:a:typo3:commerce_extension:0.9.7:*:*:*:*:*:*:* | 0.9.7 | Vulnerable | TYPO3 |
| cpe:2.3:a:typo3:typo3:*:*:*:*:*:*:*:* | all versions | Running on | TYPO3 |
- cpe:2.3:a:typo3:commerce_extension:*:*:*:*:*:*:*:* Versions up to 0.9.8 Vulnerable ·TYPO3
- cpe:2.3:a:typo3:commerce_extension:0.8.32:*:*:*:*:*:*:* Versions 0.8.32 Vulnerable ·TYPO3
- cpe:2.3:a:typo3:commerce_extension:0.8.35:*:*:*:*:*:*:* Versions 0.8.35 Vulnerable ·TYPO3
- cpe:2.3:a:typo3:commerce_extension:0.9.0:*:*:*:*:*:*:* Versions 0.9.0 Vulnerable ·TYPO3
- cpe:2.3:a:typo3:commerce_extension:0.9.5:*:*:*:*:*:*:* Versions 0.9.5 Vulnerable ·TYPO3
- cpe:2.3:a:typo3:commerce_extension:0.9.6:*:*:*:*:*:*:* Versions 0.9.6 Vulnerable ·TYPO3
- cpe:2.3:a:typo3:commerce_extension:0.9.7:*:*:*:*:*:*:* Versions 0.9.7 Vulnerable ·TYPO3
- cpe:2.3:a:typo3:typo3:*:*:*:*:*:*:*:* Versions all versions Running on ·TYPO3
Remediation
- Fix · GHSA-rmc9-5546-5rrf commerceteam/commerce (Packagist) Fixed in 0.9.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2009-4963
- 2026-10-03 Alias added: GHSA-rmc9-5546-5rrf
References
More TYPO3 Commerce Extension vulnerabilities
- TI-2008-05325 SQL injection vulnerability in the Commerce extension 0.9.6 and earlier for TYPO3 allows… CVSS 2.0HIGH 7.5
Sources
- CVE-2009-4963 · CVE Program
- CVE-2009-4963 · NVD
- FIRST EPSS
- GHSA-rmc9-5546-5rrf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences