python-docutils allows insecure usage of temporary files
Priority MEDIUM 42CWE-668Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
python-docutils allows insecure usage of temporary files
Why it matters now
EPSS 0.01427 73rd percentileScored 2026-11-07
Fix Fixed docutils (PyPI): 0.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | docutils (PyPI) | 0.5 to before 0.6 | 0.6 | Patch available | GHSA-cg75-6938-wx58 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- docutils (PyPI) Vendor— Affected 0.5 to before 0.6 Fixed in 0.6 Patch available GHSA-cg75-6938-wx58
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python-docutils_project:python-docutils:0.5-2:*:*:*:*:*:*:* | 0.5-2 | Vulnerable | Python-docutils Project |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:python-docutils_project:python-docutils:0.5-2:*:*:*:*:*:*:* Versions 0.5-2 Vulnerable ·Python-docutils Project
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-cg75-6938-wx58 docutils (PyPI) Fixed in 0.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2009-5042
- 2026-10-03 Alias added: GHSA-cg75-6938-wx58
References
Advisory 3
Sources
- CVE-2009-5042 · CVE Program
- CVE-2009-5042 · NVD
- FIRST EPSS
- GHSA-cg75-6938-wx58 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences