Read the docs
TI-2010-01285 Aliases CVE-2010-1330GHSA-wmq2-jc9m-xp4m

The regular expression engine in JRuby before 1.4.1, when $KCODE is set to 'u', does not…

Priority LOW 24CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

The regular expression engine in JRuby before 1.4.1, when $KCODE is set to 'u', does not properly handle characters immediately after a UTF-8 character, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted string.

Why it matters now

EPSS 0.02218 82nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed org.jruby:jruby-core (Maven): 1.4.1Red Hat: 1 advisory

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jruby:jruby-core (Maven)before 1.4.11.4.1Patch availableGHSA-wmq2-jc9m-xp4m
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jruby:jruby-core (Maven) Vendor— Affected before 1.4.1 Fixed in 1.4.1 Patch available GHSA-wmq2-jc9m-xp4m

CPE configurations NVD · 35

CPEVersionsRoleVendor
cpe:2.3:a:jruby:jruby:*:*:*:*:*:*:*:*up to 1.4.0Vulnerablejruby
cpe:2.3:a:jruby:jruby:0.9.0:*:*:*:*:*:*:*0.9.0Vulnerablejruby
cpe:2.3:a:jruby:jruby:0.9.1:*:*:*:*:*:*:*0.9.1Vulnerablejruby
cpe:2.3:a:jruby:jruby:0.9.2:*:*:*:*:*:*:*0.9.2Vulnerablejruby
cpe:2.3:a:jruby:jruby:0.9.8:*:*:*:*:*:*:*0.9.8Vulnerablejruby
cpe:2.3:a:jruby:jruby:0.9.9:*:*:*:*:*:*:*0.9.9Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.0.0:*:*:*:*:*:*:*1.0.0Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.0.0:rc1:*:*:*:*:*:*1.0.0 rc1Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.0.0:rc2:*:*:*:*:*:*1.0.0 rc2Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.0.0:rc3:*:*:*:*:*:*1.0.0 rc3Vulnerablejruby
  • cpe:2.3:a:jruby:jruby:*:*:*:*:*:*:*:* Versions up to 1.4.0 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:0.9.0:*:*:*:*:*:*:* Versions 0.9.0 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:0.9.1:*:*:*:*:*:*:* Versions 0.9.1 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:0.9.2:*:*:*:*:*:*:* Versions 0.9.2 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:0.9.8:*:*:*:*:*:*:* Versions 0.9.8 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:0.9.9:*:*:*:*:*:*:* Versions 0.9.9 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.0.0:rc1:*:*:*:*:*:* Versions 1.0.0 rc1 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.0.0:rc2:*:*:*:*:*:* Versions 1.0.0 rc2 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.0.0:rc3:*:*:*:*:*:* Versions 1.0.0 rc3 Vulnerable ·jruby
Show 25 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:jruby:jruby:1.0.1:*:*:*:*:*:*:*1.0.1Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.0.2:*:*:*:*:*:*:*1.0.2Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.0.3:*:*:*:*:*:*:*1.0.3Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.1:*:*:*:*:*:*:*1.1Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.1:beta1:*:*:*:*:*:*1.1 beta1Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.1:rc1:*:*:*:*:*:*1.1 rc1Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.1:rc2:*:*:*:*:*:*1.1 rc2Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.1:rc3:*:*:*:*:*:*1.1 rc3Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.1.1:*:*:*:*:*:*:*1.1.1Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.1.2:*:*:*:*:*:*:*1.1.2Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.1.3:*:*:*:*:*:*:*1.1.3Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.1.4:*:*:*:*:*:*:*1.1.4Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.1.5:*:*:*:*:*:*:*1.1.5Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.1.6:*:*:*:*:*:*:*1.1.6Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.1.6:rc1:*:*:*:*:*:*1.1.6 rc1Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.2.0:*:*:*:*:*:*:*1.2.0Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.2.0:rc1:*:*:*:*:*:*1.2.0 rc1Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.2.0:rc2:*:*:*:*:*:*1.2.0 rc2Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.3.0:*:*:*:*:*:*:*1.3.0Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.3.0:rc1:*:*:*:*:*:*1.3.0 rc1Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.3.0:rc2:*:*:*:*:*:*1.3.0 rc2Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.3.1:*:*:*:*:*:*:*1.3.1Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.4.0:rc1:*:*:*:*:*:*1.4.0 rc1Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.4.0:rc2:*:*:*:*:*:*1.4.0 rc2Vulnerablejruby
cpe:2.3:a:jruby:jruby:1.4.0:rc3:*:*:*:*:*:*1.4.0 rc3Vulnerablejruby
  • cpe:2.3:a:jruby:jruby:1.0.1:*:*:*:*:*:*:* Versions 1.0.1 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.0.2:*:*:*:*:*:*:* Versions 1.0.2 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.0.3:*:*:*:*:*:*:* Versions 1.0.3 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.1:*:*:*:*:*:*:* Versions 1.1 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.1:beta1:*:*:*:*:*:* Versions 1.1 beta1 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.1:rc1:*:*:*:*:*:* Versions 1.1 rc1 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.1:rc2:*:*:*:*:*:* Versions 1.1 rc2 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.1:rc3:*:*:*:*:*:* Versions 1.1 rc3 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.1.1:*:*:*:*:*:*:* Versions 1.1.1 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.1.2:*:*:*:*:*:*:* Versions 1.1.2 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.1.3:*:*:*:*:*:*:* Versions 1.1.3 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.1.4:*:*:*:*:*:*:* Versions 1.1.4 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.1.5:*:*:*:*:*:*:* Versions 1.1.5 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.1.6:*:*:*:*:*:*:* Versions 1.1.6 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.1.6:rc1:*:*:*:*:*:* Versions 1.1.6 rc1 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.2.0:*:*:*:*:*:*:* Versions 1.2.0 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.2.0:rc1:*:*:*:*:*:* Versions 1.2.0 rc1 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.2.0:rc2:*:*:*:*:*:* Versions 1.2.0 rc2 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.3.0:*:*:*:*:*:*:* Versions 1.3.0 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.3.0:rc1:*:*:*:*:*:* Versions 1.3.0 rc1 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.3.0:rc2:*:*:*:*:*:* Versions 1.3.0 rc2 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.3.1:*:*:*:*:*:*:* Versions 1.3.1 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.4.0:rc1:*:*:*:*:*:* Versions 1.4.0 rc1 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.4.0:rc2:*:*:*:*:*:* Versions 1.4.0 rc2 Vulnerable ·jruby
  • cpe:2.3:a:jruby:jruby:1.4.0:rc3:*:*:*:*:*:* Versions 1.4.0 rc3 Vulnerable ·jruby

Remediation

  • Fix · GHSA-wmq2-jc9m-xp4m org.jruby:jruby-core (Maven) Fixed in 1.4.1 Advisory →

Red Hat 1 advisory

  • RHSA-2011:1456 Released 2011-11-16 · Red Hat rating Moderate
    JBoss Enterprise SOA Platform 5.2.0 update
    • Red Hat JBoss SOA Platform 5.1

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat JBoss SOA Platform 5.1Fixed RHSA-2011:1456

Timeline

  1. 2026-10-02 Threatist record created from CVE-2010-1330
  2. 2026-10-03 Alias added: GHSA-wmq2-jc9m-xp4m

References

  • TI-2025-29269 JRuby-OpenSSL has hostname verification disabled by default CVSS 4.0MEDIUM 5.7
  • TI-2011-04166 JRuby before 1.6.5.1 computes hash values without restricting the ability to trigger hash… CVSS 2.0MEDIUM 5.0
  • TI-2012-04543 JRuby computes hash values without properly restricting the ability to trigger hash… CVSS 2.0MEDIUM 5.0

Sources