Cross-site scripting (XSS) vulnerability in axis2-admin/axis2-admin/engagingglobally in…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in axis2-admin/axis2-admin/engagingglobally in the administration console in Apache Axis2/Java 1.4.1, 1.5.1, and possibly other versions, as used in SAP Business Objects 12, 3com IMC, and possibly other products, allows remote attackers to inject arbitrary web script or HTML via the modules parameter. NOTE: some of these details are obtained from third party information.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.axis2.wso2:axis2 (Maven) | 1.4.1 to before 1.6.0 | 1.6.0 | Patch available | GHSA-23x8-j7hm-5xwf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.axis2.wso2:axis2 (Maven) Vendor— Affected 1.4.1 to before 1.6.0 Fixed in 1.6.0 Patch available GHSA-23x8-j7hm-5xwf
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:axis2:1.4.1:*:*:*:*:*:*:* | 1.4.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:axis2:1.5.1:*:*:*:*:*:*:* | 1.5.1 | Vulnerable | Apache |
| cpe:2.3:a:3com:intelligent_management_center:*:*:*:*:*:*:*:* | all versions | Running on | 3com |
| cpe:2.3:a:sap:business_objects:12:*:*:*:*:*:*:* | 12 | Running on | SAP |
- cpe:2.3:a:apache:axis2:1.4.1:*:*:*:*:*:*:* Versions 1.4.1 Vulnerable ·Apache
- cpe:2.3:a:apache:axis2:1.5.1:*:*:*:*:*:*:* Versions 1.5.1 Vulnerable ·Apache
- cpe:2.3:a:3com:intelligent_management_center:*:*:*:*:*:*:*:* Versions all versions Running on ·3com
- cpe:2.3:a:sap:business_objects:12:*:*:*:*:*:*:* Versions 12 Running on ·SAP
Remediation
- Fix · GHSA-23x8-j7hm-5xwf org.apache.axis2.wso2:axis2 (Maven) Fixed in 1.6.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
Timeline
- 2026-10-02 Threatist record created from CVE-2010-2103
- 2026-10-03 Alias added: GHSA-23x8-j7hm-5xwf
References
More Apache Axis2 vulnerabilities
- TI-2010-00211 Apache Axis2, as used in dswsbobje.war in SAP BusinessObjects Enterprise XI 3.2, CA… CVSS 2.0HIGH 10.0
- TI-2010-01575 Apache Axis2 before 1.5.2, as used in IBM WebSphere Application Server (WAS) 7.0 through… CVSS 2.0HIGH 7.5
- TI-2012-04525 Apache Axis2 allows remote attackers to forge messages and bypass authentication via a… CVSS 2.0MEDIUM 6.4
- TI-2012-03760 Apache Axis2 allows remote attackers to forge messages and bypass authentication via an "XML Signature wrapping attack." CVSS 2.0MEDIUM 5.8
- TI-2012-04826 Apache Axis2/Java 1.6.2 and earlier does not verify that the server hostname matches a… CVSS 2.0MEDIUM 5.8
Sources
- CVE-2010-2103 · CVE Program
- CVE-2010-2103 · NVD
- FIRST EPSS
- GHSA-23x8-j7hm-5xwf · GitHub Advisory Database · CC BY 4.0
- CVE-2010-2103 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences