It was found that all OWASP ESAPI for Java up to version 2.0 RC2 are vulnerable to padding oracle attacks.
Priority LOW 27CWE-649Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
It was found that all OWASP ESAPI for Java up to version 2.0 RC2 are vulnerable to padding oracle attacks.
Why it matters now
EPSS 0.0045 39th percentileScored 2026-11-07
Fix Fixed org.owasp.esapi:esapi (Maven): 2.0GA
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | OWASP ESAPI | OWASP ESAPI for Java up to version 2.0 RC2 | — | No fix listed | CNA |
| — | org.owasp.esapi:esapi (Maven) | before 2.0GA | 2.0GA | Patch available | GHSA-3gp6-hhfw-4gqx |
- OWASP ESAPI Vendor— Affected OWASP ESAPI for Java up to version 2.0 RC2 Fixed in — No fix listed CNA
- org.owasp.esapi:esapi (Maven) Vendor— Affected before 2.0GA Fixed in 2.0GA Patch available GHSA-3gp6-hhfw-4gqx
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:owasp:enterprise_security_api_for_java:*:*:*:*:*:*:*:* | before 2.0 | Vulnerable | owasp-modsecurity |
| cpe:2.3:a:owasp:enterprise_security_api_for_java:2.0:-:*:*:*:*:*:* | 2.0 | Vulnerable | owasp-modsecurity |
| cpe:2.3:a:owasp:enterprise_security_api_for_java:2.0:rc1:*:*:*:*:*:* | 2.0 rc1 | Vulnerable | owasp-modsecurity |
- cpe:2.3:a:owasp:enterprise_security_api_for_java:*:*:*:*:*:*:*:* Versions before 2.0 Vulnerable ·owasp-modsecurity
- cpe:2.3:a:owasp:enterprise_security_api_for_java:2.0:-:*:*:*:*:*:* Versions 2.0 Vulnerable ·owasp-modsecurity
- cpe:2.3:a:owasp:enterprise_security_api_for_java:2.0:rc1:*:*:*:*:*:* Versions 2.0 rc1 Vulnerable ·owasp-modsecurity
Remediation
- Fix · GHSA-3gp6-hhfw-4gqx org.owasp.esapi:esapi (Maven) Fixed in 2.0GA Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2010-3300
- 2026-10-03 Alias added: GHSA-3gp6-hhfw-4gqx
References
Sources
- CVE-2010-3300 · CVE Program
- CVE-2010-3300 · NVD
- FIRST EPSS
- GHSA-3gp6-hhfw-4gqx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences