phpgwapi/js/fckeditor/editor/dialog/fck_spellerpages/spellerpages/serverscripts/spellchec…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
phpgwapi/js/fckeditor/editor/dialog/fck_spellerpages/spellerpages/serverscripts/spellchecker.php in EGroupware 1.4.001+.002; 1.6.001+.002 and possibly other versions before 1.6.003; and EPL 9.1 before 9.1.20100309 and 9.2 before 9.2.20100309; allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) aspell_path or (2) spellchecker_lang parameters.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | egroupware/egroupware (Packagist) | before 1.6.003 | 1.6.003 | Patch available | GHSA-5gx6-f2qq-475f |
| — | egroupware/egroupware (Packagist) | 9.1 to before 9.1.20100309 | 9.1.20100309 | Patch available | GHSA-5gx6-f2qq-475f |
| — | egroupware/egroupware (Packagist) | 9.2 to before 9.2.20100309 | 9.2.20100309 | Patch available | GHSA-5gx6-f2qq-475f |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- egroupware/egroupware (Packagist) Vendor— Affected before 1.6.003 Fixed in 1.6.003 Patch available GHSA-5gx6-f2qq-475f
- egroupware/egroupware (Packagist) Vendor— Affected 9.1 to before 9.1.20100309 Fixed in 9.1.20100309 Patch available GHSA-5gx6-f2qq-475f
- egroupware/egroupware (Packagist) Vendor— Affected 9.2 to before 9.2.20100309 Fixed in 9.2.20100309 Patch available GHSA-5gx6-f2qq-475f
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:egroupware:egroupware:1.4.001:*:*:*:*:*:*:* | 1.4.001 | Vulnerable | EGroupware |
| cpe:2.3:a:egroupware:egroupware:1.4.001\+.002:*:*:*:*:*:*:* | 1.4.001+.002 | Vulnerable | EGroupware |
| cpe:2.3:a:egroupware:egroupware:1.4.002:*:*:*:*:*:*:* | 1.4.002 | Vulnerable | EGroupware |
| cpe:2.3:a:egroupware:egroupware:1.6.001:*:*:*:*:*:*:* | 1.6.001 | Vulnerable | EGroupware |
| cpe:2.3:a:egroupware:egroupware:1.6.001\+.002:*:*:*:*:*:*:* | 1.6.001+.002 | Vulnerable | EGroupware |
| cpe:2.3:a:egroupware:egroupware:1.6.002:*:*:*:*:*:*:* | 1.6.002 | Vulnerable | EGroupware |
| cpe:2.3:a:egroupware:egroupware:9.1:-:commercial_epl:*:*:*:*:* | 9.1 | Vulnerable | EGroupware |
| cpe:2.3:a:egroupware:egroupware:9.2:-:commercial_epl:*:*:*:*:* | 9.2 | Vulnerable | EGroupware |
- cpe:2.3:a:egroupware:egroupware:1.4.001:*:*:*:*:*:*:* Versions 1.4.001 Vulnerable ·EGroupware
- cpe:2.3:a:egroupware:egroupware:1.4.001\+.002:*:*:*:*:*:*:* Versions 1.4.001+.002 Vulnerable ·EGroupware
- cpe:2.3:a:egroupware:egroupware:1.4.002:*:*:*:*:*:*:* Versions 1.4.002 Vulnerable ·EGroupware
- cpe:2.3:a:egroupware:egroupware:1.6.001:*:*:*:*:*:*:* Versions 1.6.001 Vulnerable ·EGroupware
- cpe:2.3:a:egroupware:egroupware:1.6.001\+.002:*:*:*:*:*:*:* Versions 1.6.001+.002 Vulnerable ·EGroupware
- cpe:2.3:a:egroupware:egroupware:1.6.002:*:*:*:*:*:*:* Versions 1.6.002 Vulnerable ·EGroupware
- cpe:2.3:a:egroupware:egroupware:9.1:-:commercial_epl:*:*:*:*:* Versions 9.1 Vulnerable ·EGroupware
- cpe:2.3:a:egroupware:egroupware:9.2:-:commercial_epl:*:*:*:*:* Versions 9.2 Vulnerable ·EGroupware
Remediation
- Fix · GHSA-5gx6-f2qq-475f egroupware/egroupware (Packagist) Fixed in 1.6.003 Advisory →
- Fix · GHSA-5gx6-f2qq-475f egroupware/egroupware (Packagist) Fixed in 9.1.20100309 Advisory →
- Fix · GHSA-5gx6-f2qq-475f egroupware/egroupware (Packagist) Fixed in 9.2.20100309 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2010-3313
- 2026-10-03 Alias added: GHSA-5gx6-f2qq-475f
- 2026-10-21 EPSS moved to the 95th–99th percentile
- 2026-10-25 EPSS moved to the 90th–95th percentile
- 2026-10-26 EPSS moved to the 95th–99th percentile
References
More Egroupware vulnerabilities
- TI-2024-27031 EGroupware before 23.1.20240624 mishandles an ORDER BY clause. CVSS 3.1CRITICAL 9.8
- TI-2026-17853 EGroupware has SQL Injection in Nextmatch Filter Processing CVSS 4.0HIGH 8.7
- TI-2007-03051 Unspecified vulnerability in Walter Zorn wz_tooltip.js (aka wz_tooltips) before 4.01, as… CVSS 2.0HIGH 10.0
- TI-2008-01961 Multiple unspecified vulnerabilities in eGroupWare before 1.4.004 have unspecified attack… CVSS 2.0HIGH 10.0
- TI-2007-03052 Unspecified vulnerability in eGroupWare before 1.2.107-2 has unknown impact and attack… CVSS 2.0HIGH 10.0
- TI-2014-02389 EGroupware Enterprise Line (EPL) before 1.1.20140505, EGroupware Community Edition before… CVSS 2.0HIGH 8.5
Sources
- CVE-2010-3313 · CVE Program
- CVE-2010-3313 · NVD
- FIRST EPSS
- GHSA-5gx6-f2qq-475f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences