libpoe-component-irc-perl before v6.32 does not remove carriage returns and line feeds.
Priority MEDIUM 45CWE-134Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-134 and the CVSS impact.
Summary
libpoe-component-irc-perl before v6.32 does not remove carriage returns and line feeds. This can be used to execute arbitrary IRC commands by passing an argument such as "some text\rQUIT" to the 'privmsg' handler, which would cause the client to disconnect from the server.
Why it matters now
EPSS 0.01652 76th percentileScored 2026-11-07
Fix Fixed libpoe-component-irc-perl (libpoe-component-irc-perl): v6.32
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| libpoe-component-irc-perl | libpoe-component-irc-perl | before v6.32 | v6.32 | Patch available | CNA |
- libpoe-component-irc-perl Vendorlibpoe-component-irc-perl Affected before v6.32 Fixed in v6.32 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libpoe-component-irc-perl_project:libpoe-component-irc-perl:*:*:*:*:*:*:*:* | before 6.32 | Vulnerable | Libpoe-component-irc-perl Project |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:12:*:*:*:*:*:*:* | 12 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:13:*:*:*:*:*:*:* | 13 | Vulnerable | Fedoraproject |
- cpe:2.3:a:libpoe-component-irc-perl_project:libpoe-component-irc-perl:*:*:*:*:*:*:*:* Versions before 6.32 Vulnerable ·Libpoe-component-irc-perl Project
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:12:*:*:*:*:*:*:* Versions 12 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:13:*:*:*:*:*:*:* Versions 13 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA libpoe-component-irc-perl (libpoe-component-irc-perl) Fixed in v6.32
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2010-3438
- 2026-10-03 Alias added: GHSA-vqr8-85pj-78rw
References
Sources
- CVE-2010-3438 · CVE Program
- CVE-2010-3438 · NVD
- FIRST EPSS
- GHSA-vqr8-85pj-78rw · GitHub Advisory Database · CC BY 4.0
- CVE-2010-3438 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences