babiloo 2.0.9 before 2.0.11 creates temporary files with predictable names when…
Priority LOW 24CWE-494Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-494.
Summary
babiloo 2.0.9 before 2.0.11 creates temporary files with predictable names when downloading and unpacking dictionary files, allowing a local attacker to overwrite arbitrary files.
Why it matters now
EPSS 0.00256 17th percentileScored 2026-11-07
Fix Fixed babiloo (babiloo): 2.0.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| babiloo | babiloo | 2.0.9 to before 2.0.11 | 2.0.11 | Patch available | CNA |
- babiloo Vendorbabiloo Affected 2.0.9 to before 2.0.11 Fixed in 2.0.11 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:babiloo_project:babiloo:*:*:*:*:*:*:*:* | 2.0.9 to before 2.0.11 | Vulnerable | Babiloo Project |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:babiloo_project:babiloo:*:*:*:*:*:*:*:* Versions 2.0.9 to before 2.0.11 Vulnerable ·Babiloo Project
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA babiloo (babiloo) Fixed in 2.0.11
Timeline
- 2026-10-02 Threatist record created from CVE-2010-3440
- 2026-10-03 Alias added: GHSA-9pf6-3wxm-2rg5
References
Sources
- CVE-2010-3440 · CVE Program
- CVE-2010-3440 · NVD
- FIRST EPSS
- GHSA-9pf6-3wxm-2rg5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences