Read the docs
TI-2010-03440 Aliases CVE-2010-3613GHSA-7hh4-vqqp-5g89

named in ISC BIND 9.6.2 before 9.6.2-P3, 9.6-ESV before 9.6-ESV-R3, and 9.7.x before…

Priority LOW 30CWE-264Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · None · Partial
Fix status
Partial Red Hat: 15 fixed, 1 without a fix

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-264.

Summary

named in ISC BIND 9.6.2 before 9.6.2-P3, 9.6-ESV before 9.6-ESV-R3, and 9.7.x before 9.7.2-P3 does not properly handle the combination of signed negative responses and corresponding RRSIG records in the cache, which allows remote attackers to cause a denial of service (daemon crash) via a query for cached data.

Why it matters now

EPSS 0.091 95th percentileScored 2026-11-07
Fix Partial Red Hat: 3 advisoriesRed Hat: 15 fixed, 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 26

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.6:*:*:*:esv:*:*:*9.6VulnerableISC
cpe:2.3:a:isc:bind:9.6:r1:*:*:esv:*:*:*9.6 r1VulnerableISC
cpe:2.3:a:isc:bind:9.6:r2:*:*:esv:*:*:*9.6 r2VulnerableISC
cpe:2.3:a:isc:bind:9.6.2:*:*:*:*:*:*:*9.6.2VulnerableISC
cpe:2.3:a:isc:bind:9.6.2:b1:*:*:*:*:*:*9.6.2 b1VulnerableISC
cpe:2.3:a:isc:bind:9.6.2:p1:*:*:*:*:*:*9.6.2 p1VulnerableISC
cpe:2.3:a:isc:bind:9.6.2:p2:*:*:*:*:*:*9.6.2 p2VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:*:*:*:*:*:*:*9.7.0VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:a1:*:*:*:*:*:*9.7.0 a1VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:a2:*:*:*:*:*:*9.7.0 a2VulnerableISC
  • cpe:2.3:a:isc:bind:9.6:*:*:*:esv:*:*:* Versions 9.6 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6:r1:*:*:esv:*:*:* Versions 9.6 r1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6:r2:*:*:esv:*:*:* Versions 9.6 r2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.2:*:*:*:*:*:*:* Versions 9.6.2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.2:b1:*:*:*:*:*:* Versions 9.6.2 b1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.2:p1:*:*:*:*:*:* Versions 9.6.2 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.2:p2:*:*:*:*:*:* Versions 9.6.2 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:*:*:*:*:*:*:* Versions 9.7.0 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:a1:*:*:*:*:*:* Versions 9.7.0 a1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:a2:*:*:*:*:*:* Versions 9.7.0 a2 Vulnerable ·ISC
Show 16 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.7.0:a3:*:*:*:*:*:*9.7.0 a3VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:b1:*:*:*:*:*:*9.7.0 b1VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:b2:*:*:*:*:*:*9.7.0 b2VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:b3:*:*:*:*:*:*9.7.0 b3VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:p1:*:*:*:*:*:*9.7.0 p1VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:p2:*:*:*:*:*:*9.7.0 p2VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:rc1:*:*:*:*:*:*9.7.0 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:rc2:*:*:*:*:*:*9.7.0 rc2VulnerableISC
cpe:2.3:a:isc:bind:9.7.1:*:*:*:*:*:*:*9.7.1VulnerableISC
cpe:2.3:a:isc:bind:9.7.1:b1:*:*:*:*:*:*9.7.1 b1VulnerableISC
cpe:2.3:a:isc:bind:9.7.1:p1:*:*:*:*:*:*9.7.1 p1VulnerableISC
cpe:2.3:a:isc:bind:9.7.1:p2:*:*:*:*:*:*9.7.1 p2VulnerableISC
cpe:2.3:a:isc:bind:9.7.1:rc1:*:*:*:*:*:*9.7.1 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.7.2:*:*:*:*:*:*:*9.7.2VulnerableISC
cpe:2.3:a:isc:bind:9.7.2:p1:*:*:*:*:*:*9.7.2 p1VulnerableISC
cpe:2.3:a:isc:bind:9.7.2:p2:*:*:*:*:*:*9.7.2 p2VulnerableISC
  • cpe:2.3:a:isc:bind:9.7.0:a3:*:*:*:*:*:* Versions 9.7.0 a3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:b1:*:*:*:*:*:* Versions 9.7.0 b1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:b2:*:*:*:*:*:* Versions 9.7.0 b2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:b3:*:*:*:*:*:* Versions 9.7.0 b3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:p1:*:*:*:*:*:* Versions 9.7.0 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:p2:*:*:*:*:*:* Versions 9.7.0 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:rc1:*:*:*:*:*:* Versions 9.7.0 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:rc2:*:*:*:*:*:* Versions 9.7.0 rc2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.1:*:*:*:*:*:*:* Versions 9.7.1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.1:b1:*:*:*:*:*:* Versions 9.7.1 b1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.1:p1:*:*:*:*:*:* Versions 9.7.1 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.1:p2:*:*:*:*:*:* Versions 9.7.1 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.1:rc1:*:*:*:*:*:* Versions 9.7.1 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.2:*:*:*:*:*:*:* Versions 9.7.2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.2:p1:*:*:*:*:*:* Versions 9.7.2 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.2:p2:*:*:*:*:*:* Versions 9.7.2 p2 Vulnerable ·ISC

Remediation

Red Hat 3 advisories

  • RHSA-2010:1000 Released 2010-12-20 · Red Hat rating Important
    bind security update
    • Red Hat Enterprise Linux AS version 4 bind-20:9.2.4-30.el4_8.6, bind-20:9.2.4-30.el4_8.6.i386, bind-20:9.2.4-30.el4_8.6.ia64 +17
    • Red Hat Enterprise Linux Desktop version 4 bind-20:9.2.4-30.el4_8.6, bind-20:9.2.4-30.el4_8.6.i386, bind-chroot-20:9.2.4-30.el4_8.6 +7
    • Red Hat Enterprise Linux ES version 4 bind-20:9.2.4-30.el4_8.6, bind-20:9.2.4-30.el4_8.6.i386, bind-20:9.2.4-30.el4_8.6.ia64 +12
    • Red Hat Enterprise Linux WS version 4 bind-20:9.2.4-30.el4_8.6, bind-20:9.2.4-30.el4_8.6.i386, bind-20:9.2.4-30.el4_8.6.ia64 +12
  • RHSA-2010:0976 Released 2010-12-13 · Red Hat rating Important
    bind security update
    • Red Hat Enterprise Linux (v. 5 server) bind-30:9.3.6-4.P1.el5_5.3, bind-30:9.3.6-4.P1.el5_5.3.i386, bind-30:9.3.6-4.P1.el5_5.3.ia64 +29
    • Red Hat Enterprise Linux Desktop (v. 5 client) bind-30:9.3.6-4.P1.el5_5.3, bind-30:9.3.6-4.P1.el5_5.3.i386, bind-libs-30:9.3.6-4.P1.el5_5.3 +5
    • Red Hat Enterprise Linux Desktop Workstation (v. 5 client) bind-30:9.3.6-4.P1.el5_5.3, bind-chroot-30:9.3.6-4.P1.el5_5.3, bind-chroot-30:9.3.6-4.P1.el5_5.3.i386 +6
  • RHSA-2010:0975 Released 2010-12-13 · Red Hat rating Important
    bind security update
    • Red Hat Enterprise Linux Desktop (v. 6) bind-32:9.7.0-5.P2.el6_0.1, bind-libs-32:9.7.0-5.P2.el6_0.1, bind-utils-32:9.7.0-5.P2.el6_0.1
    • Red Hat Enterprise Linux Desktop Optional (v. 6) bind-32:9.7.0-5.P2.el6_0.1, bind-chroot-32:9.7.0-5.P2.el6_0.1, bind-devel-32:9.7.0-5.P2.el6_0.1 +2
    • Red Hat Enterprise Linux HPC Node (v. 6) bind-32:9.7.0-5.P2.el6_0.1, bind-libs-32:9.7.0-5.P2.el6_0.1, bind-utils-32:9.7.0-5.P2.el6_0.1
    • Red Hat Enterprise Linux HPC Node Optional (v. 6) bind-32:9.7.0-5.P2.el6_0.1, bind-chroot-32:9.7.0-5.P2.el6_0.1, bind-devel-32:9.7.0-5.P2.el6_0.1 +2
    • Red Hat Enterprise Linux Server (v. 6) bind-32:9.7.0-5.P2.el6_0.1, bind-chroot-32:9.7.0-5.P2.el6_0.1, bind-libs-32:9.7.0-5.P2.el6_0.1 +1
    • Red Hat Enterprise Linux Server Optional (v. 6) bind-32:9.7.0-5.P2.el6_0.1, bind-devel-32:9.7.0-5.P2.el6_0.1, bind-devel-32:9.7.0-5.P2.el6_0.1.ppc +3
    • Red Hat Enterprise Linux Workstation (v. 6) bind-32:9.7.0-5.P2.el6_0.1, bind-chroot-32:9.7.0-5.P2.el6_0.1, bind-libs-32:9.7.0-5.P2.el6_0.1 +1
    • Red Hat Enterprise Linux Workstation Optional (v. 6) bind-32:9.7.0-5.P2.el6_0.1, bind-devel-32:9.7.0-5.P2.el6_0.1, bind-libs-32:9.7.0-5.P2.el6_0.1 +1

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 5AffectedNo fix yet
Red Hat Enterprise Linux (v. 5 server)Fixed RHSA-2010:0976
Red Hat Enterprise Linux AS version 4Fixed RHSA-2010:1000
Red Hat Enterprise Linux Desktop (v. 5 client)Fixed RHSA-2010:0976
Red Hat Enterprise Linux Desktop (v. 6)Fixed RHSA-2010:0975
Red Hat Enterprise Linux Desktop Optional (v. 6)Fixed RHSA-2010:0975
Red Hat Enterprise Linux Desktop Workstation (v. 5 client)Fixed RHSA-2010:0976
Red Hat Enterprise Linux Desktop version 4Fixed RHSA-2010:1000
Red Hat Enterprise Linux ES version 4Fixed RHSA-2010:1000
Red Hat Enterprise Linux HPC Node (v. 6)Fixed RHSA-2010:0975
Red Hat Enterprise Linux HPC Node Optional (v. 6)Fixed RHSA-2010:0975
Red Hat Enterprise Linux Server (v. 6)Fixed RHSA-2010:0975
Red Hat Enterprise Linux Server Optional (v. 6)Fixed RHSA-2010:0975
Red Hat Enterprise Linux WS version 4Fixed RHSA-2010:1000
Red Hat Enterprise Linux Workstation (v. 6)Fixed RHSA-2010:0975
Red Hat Enterprise Linux Workstation Optional (v. 6)Fixed RHSA-2010:0975

Timeline

  1. 2026-10-02 Threatist record created from CVE-2010-3613
  2. 2026-10-03 Alias added: GHSA-7hh4-vqqp-5g89

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources