Read the docs
TI-2010-03574 Aliases CVE-2010-3762GHSA-hv8v-8gq8-6q29

ISC BIND before 9.7.2-P2, when DNSSEC validation is enabled, does not properly handle…

Priority LOW 31CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
—
Confidentiality · integrity · availability
None · None · Partial
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat.

Summary

ISC BIND before 9.7.2-P2, when DNSSEC validation is enabled, does not properly handle certain bad signatures if multiple trust anchors exist for a single zone, which allows remote attackers to cause a denial of service (daemon crash) via a DNS query.

Why it matters now

EPSS 0.08086 94th percentileScored 2026-11-07
Fix Fixed Red Hat: 1 advisory

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:*:p2:*:*:*:*:*:*up to 9.7.2VulnerableISC
  • cpe:2.3:a:isc:bind:*:p2:*:*:*:*:*:* Versions up to 9.7.2 Vulnerable ·ISC

Remediation

Red Hat 1 advisory

  • RHSA-2010:0976 Released 2010-12-13 · Red Hat rating Important
    bind security update
    • Red Hat Enterprise Linux (v. 5 server) bind-30:9.3.6-4.P1.el5_5.3, bind-30:9.3.6-4.P1.el5_5.3.i386, bind-30:9.3.6-4.P1.el5_5.3.ia64 +29
    • Red Hat Enterprise Linux Desktop (v. 5 client) bind-30:9.3.6-4.P1.el5_5.3, bind-30:9.3.6-4.P1.el5_5.3.i386, bind-libs-30:9.3.6-4.P1.el5_5.3 +5
    • Red Hat Enterprise Linux Desktop Workstation (v. 5 client) bind-30:9.3.6-4.P1.el5_5.3, bind-chroot-30:9.3.6-4.P1.el5_5.3, bind-chroot-30:9.3.6-4.P1.el5_5.3.i386 +6

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux (v. 5 server)Fixed RHSA-2010:0976
Red Hat Enterprise Linux Desktop (v. 5 client)Fixed RHSA-2010:0976
Red Hat Enterprise Linux Desktop Workstation (v. 5 client)Fixed RHSA-2010:0976
Not affected: 3 products
  • Red Hat Enterprise Linux 4
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2010-3762
  2. 2026-10-03 Alias added: GHSA-hv8v-8gq8-6q29

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources