The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x…
Priority HIGH 66CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x through 1.3.5 and 1.2.8 allows remote attackers to modify the internal Cake cache and execute arbitrary code via a crafted data[_Token][fields] value that is processed by the unserialize function, as demonstrated by modifying the file_map cache to execute arbitrary local files.
Why it matters now
EPSS 0.55204 99th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by the CNA and NVD
Fix Fixed cakephp/cakephp (Packagist): 1.3.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | cakephp/cakephp (Packagist) | 1.2.8 to before 1.3.6 | 1.3.6 | Patch available | GHSA-g2vx-8v47-4vhh |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- cakephp/cakephp (Packagist) Vendor— Affected 1.2.8 to before 1.3.6 Fixed in 1.3.6 Patch available GHSA-g2vx-8v47-4vhh
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cakefoundation:cakephp:1.3.0:*:*:*:*:*:*:* | 1.3.0 | Vulnerable | Cakefoundation |
| cpe:2.3:a:cakephp:cakephp:1.2.8:*:*:*:*:*:*:* | 1.2.8 | Vulnerable | cakephp |
| cpe:2.3:a:cakephp:cakephp:1.3:dev:*:*:*:*:*:* | 1.3 dev | Vulnerable | cakephp |
| cpe:2.3:a:cakephp:cakephp:1.3.0:alpha:*:*:*:*:*:* | 1.3.0 alpha | Vulnerable | cakephp |
| cpe:2.3:a:cakephp:cakephp:1.3.0:beta:*:*:*:*:*:* | 1.3.0 beta | Vulnerable | cakephp |
| cpe:2.3:a:cakephp:cakephp:1.3.0:rc1:*:*:*:*:*:* | 1.3.0 rc1 | Vulnerable | cakephp |
| cpe:2.3:a:cakephp:cakephp:1.3.0:rc2:*:*:*:*:*:* | 1.3.0 rc2 | Vulnerable | cakephp |
| cpe:2.3:a:cakephp:cakephp:1.3.0:rc3:*:*:*:*:*:* | 1.3.0 rc3 | Vulnerable | cakephp |
| cpe:2.3:a:cakephp:cakephp:1.3.0:rc4:*:*:*:*:*:* | 1.3.0 rc4 | Vulnerable | cakephp |
| cpe:2.3:a:cakephp:cakephp:1.3.1:*:*:*:*:*:*:* | 1.3.1 | Vulnerable | cakephp |
- cpe:2.3:a:cakefoundation:cakephp:1.3.0:*:*:*:*:*:*:* Versions 1.3.0 Vulnerable ·Cakefoundation
- cpe:2.3:a:cakephp:cakephp:1.2.8:*:*:*:*:*:*:* Versions 1.2.8 Vulnerable ·cakephp
- cpe:2.3:a:cakephp:cakephp:1.3:dev:*:*:*:*:*:* Versions 1.3 dev Vulnerable ·cakephp
- cpe:2.3:a:cakephp:cakephp:1.3.0:alpha:*:*:*:*:*:* Versions 1.3.0 alpha Vulnerable ·cakephp
- cpe:2.3:a:cakephp:cakephp:1.3.0:beta:*:*:*:*:*:* Versions 1.3.0 beta Vulnerable ·cakephp
- cpe:2.3:a:cakephp:cakephp:1.3.0:rc1:*:*:*:*:*:* Versions 1.3.0 rc1 Vulnerable ·cakephp
- cpe:2.3:a:cakephp:cakephp:1.3.0:rc2:*:*:*:*:*:* Versions 1.3.0 rc2 Vulnerable ·cakephp
- cpe:2.3:a:cakephp:cakephp:1.3.0:rc3:*:*:*:*:*:* Versions 1.3.0 rc3 Vulnerable ·cakephp
- cpe:2.3:a:cakephp:cakephp:1.3.0:rc4:*:*:*:*:*:* Versions 1.3.0 rc4 Vulnerable ·cakephp
- cpe:2.3:a:cakephp:cakephp:1.3.1:*:*:*:*:*:*:* Versions 1.3.1 Vulnerable ·cakephp
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cakephp:cakephp:1.3.2:*:*:*:*:*:*:* | 1.3.2 | Vulnerable | cakephp |
| cpe:2.3:a:cakephp:cakephp:1.3.3:*:*:*:*:*:*:* | 1.3.3 | Vulnerable | cakephp |
| cpe:2.3:a:cakephp:cakephp:1.3.4:*:*:*:*:*:*:* | 1.3.4 | Vulnerable | cakephp |
| cpe:2.3:a:cakephp:cakephp:1.3.5:*:*:*:*:*:*:* | 1.3.5 | Vulnerable | cakephp |
- cpe:2.3:a:cakephp:cakephp:1.3.2:*:*:*:*:*:*:* Versions 1.3.2 Vulnerable ·cakephp
- cpe:2.3:a:cakephp:cakephp:1.3.3:*:*:*:*:*:*:* Versions 1.3.3 Vulnerable ·cakephp
- cpe:2.3:a:cakephp:cakephp:1.3.4:*:*:*:*:*:*:* Versions 1.3.4 Vulnerable ·cakephp
- cpe:2.3:a:cakephp:cakephp:1.3.5:*:*:*:*:*:*:* Versions 1.3.5 Vulnerable ·cakephp
Remediation
- Fix · GHSA-g2vx-8v47-4vhh cakephp/cakephp (Packagist) Fixed in 1.3.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2010-4335
- 2026-10-03 Alias added: GHSA-g2vx-8v47-4vhh
References
Exploit 3
Sources
- CVE-2010-4335 · CVE Program
- CVE-2010-4335 · NVD
- FIRST EPSS
- GHSA-g2vx-8v47-4vhh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences