The password reset functionality in django.contrib.auth in Django before 1.1.3, 1.2.x…
Priority LOW 29CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
The password reset functionality in django.contrib.auth in Django before 1.1.3, 1.2.x before 1.2.4, and 1.3.x before 1.3 beta 1 does not validate the length of a string representing a base36 timestamp, which allows remote attackers to cause a denial of service (resource consumption) via a URL that specifies a large base36 integer.
Why it matters now
EPSS 0.03405 88th percentileScored 2026-11-07
Fix Fixed Django (PyPI): 1.1.3, 1.2.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | before 1.1.3 | 1.1.3 | Patch available | GHSA-7wph-fc4w-wqp2 |
| — | Django (PyPI) | 1.2 to before 1.2.4 | 1.2.4 | Patch available | GHSA-7wph-fc4w-wqp2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected before 1.1.3 Fixed in 1.1.3 Patch available GHSA-7wph-fc4w-wqp2
- Django (PyPI) Vendor— Affected 1.2 to before 1.2.4 Fixed in 1.2.4 Patch available GHSA-7wph-fc4w-wqp2
CPE configurations NVD · 16
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | up to 1.1.2 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:0.91:*:*:*:*:*:*:* | 0.91 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:0.95:*:*:*:*:*:*:* | 0.95 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:0.95.1:*:*:*:*:*:*:* | 0.95.1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:0.96:*:*:*:*:*:*:* | 0.96 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.0:*:*:*:*:*:*:* | 1.0 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.0.1:*:*:*:*:*:*:* | 1.0.1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.0.2:*:*:*:*:*:*:* | 1.0.2 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.1:*:*:*:*:*:*:* | 1.1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.1.0:*:*:*:*:*:*:* | 1.1.0 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions up to 1.1.2 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:0.91:*:*:*:*:*:*:* Versions 0.91 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:0.95:*:*:*:*:*:*:* Versions 0.95 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:0.95.1:*:*:*:*:*:*:* Versions 0.95.1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:0.96:*:*:*:*:*:*:* Versions 0.96 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.0:*:*:*:*:*:*:* Versions 1.0 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.0.1:*:*:*:*:*:*:* Versions 1.0.1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.0.2:*:*:*:*:*:*:* Versions 1.0.2 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.1:*:*:*:*:*:*:* Versions 1.1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.1.0:*:*:*:*:*:*:* Versions 1.1.0 Vulnerable ·djangoproject
Show 6 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:1.2:*:*:*:*:*:*:* | 1.2 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.2.1:*:*:*:*:*:*:* | 1.2.1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.2.2:*:*:*:*:*:*:* | 1.2.2 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.2.3:*:*:*:*:*:*:* | 1.2.3 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.3:alpha1:*:*:*:*:*:* | 1.3 alpha1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.3:alpha2:*:*:*:*:*:* | 1.3 alpha2 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:1.2:*:*:*:*:*:*:* Versions 1.2 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.2.1:*:*:*:*:*:*:* Versions 1.2.1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.2.2:*:*:*:*:*:*:* Versions 1.2.2 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.2.3:*:*:*:*:*:*:* Versions 1.2.3 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.3:alpha1:*:*:*:*:*:* Versions 1.3 alpha1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.3:alpha2:*:*:*:*:*:* Versions 1.3 alpha2 Vulnerable ·djangoproject
Remediation
- Fix · GHSA-7wph-fc4w-wqp2 Django (PyPI) Fixed in 1.1.3 Advisory →
- Fix · GHSA-7wph-fc4w-wqp2 Django (PyPI) Fixed in 1.2.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2010-4535
- 2026-10-03 Alias added: GHSA-7wph-fc4w-wqp2
References
Patch 5
- http://code.djangoproject.com/changeset/15032
- [oss-security] 20101223 CVE Request -- Django 1.2.4, Django 1.1.3 and Django 1.3 beta 1 -- addressing two security flaws
- [oss-security] 20110103 Re: CVE Request -- Django 1.2.4, Django 1.1.3 and Django 1.3 beta 1 -- addressing two security flaws
- http://www.djangoproject.com/weblog/2010/dec/22/security/
- https://bugzilla.redhat.com/show_bug.cgi?id=665373
Advisory 5
Other 9
- ADV-2011-0048
- ADV-2011-0098
- https://github.com/django/django/commit/7f8dd9cbac074389af8d8fd235bf2cb657227b9a
- https://github.com/django/django/commit/d5d8942a160685c403d381a279e72e09de5489a9
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2011-29.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2011-9.yaml
- https://web.archive.org/web/20200228193349/http://www.securityfocus.com/bid/45563
- http://www.djangoproject.com/weblog/2010/dec/22/security
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2010-4535 · CVE Program
- CVE-2010-4535 · NVD
- FIRST EPSS
- GHSA-7wph-fc4w-wqp2 · GitHub Advisory Database · CC BY 4.0
- CVE-2010-4535 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences