PHP5 before 5.4.4 allows passing invalid utf-8 strings via the…
Priority LOW 36CWE-772Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-772.
Summary
PHP5 before 5.4.4 allows passing invalid utf-8 strings via the xmlTextWriterWriteAttribute, which are then misparsed by libxml2. This results in memory leak into the resulting output.
Why it matters now
EPSS 0.01541 75th percentileScored 2026-11-07
Fix Partial php5 (php5): 5.4.4Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| php5 | php5 | before 5.4.4 | 5.4.4 | Patch available | CNA |
- php5 Vendorphp5 Affected before 5.4.4 Fixed in 5.4.4 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:php:php:*:*:*:*:*:*:*:* | 5.0.0 to before 5.4.4 | Vulnerable | PHP |
| cpe:2.3:o:redhat:enterprise_linux:5.0:*:*:*:*:*:*:* | 5.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:php:php:*:*:*:*:*:*:*:* Versions 5.0.0 to before 5.4.4 Vulnerable ·PHP
- cpe:2.3:o:redhat:enterprise_linux:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · CNA php5 (php5) Fixed in 5.4.4
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
Not affected: 1 product
- Red Hat Enterprise Linux 4
Timeline
- 2026-10-02 Threatist record created from CVE-2010-4657
- 2026-10-03 Alias added: GHSA-mx27-jhrp-2gfm
References
Sources
- CVE-2010-4657 · CVE Program
- CVE-2010-4657 · NVD
- FIRST EPSS
- GHSA-mx27-jhrp-2gfm · GitHub Advisory Database · CC BY 4.0
- CVE-2010-4657 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences