PmWiki before 2.2.21 has XSS.
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
PmWiki before 2.2.21 has XSS.
Why it matters now
EPSS 0.00849 58th percentileScored 2026-11-07
Fix Fixed pmwiki (pmwiki): 2.2.21
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA pmwiki (pmwiki) Fixed in 2.2.21
Timeline
- 2026-10-02 Threatist record created from CVE-2010-4662
- 2026-10-03 Alias added: GHSA-xg94-r739-55h8
References
More Pmwiki vulnerabilities
- TI-2011-03856 The PageListSort function in scripts/pagelist.php in PmWiki 2.x before 2.2.35 allows… CVSS 2.0HIGH 7.5
- TI-2006-02748 Cross-site scripting (XSS) vulnerability in (1) uploads.php and (2) "url links" in PmWiki… CVSS 2.0MEDIUM 6.8
- TI-2006-00465 pmwiki.php in PmWiki 2.1 beta 20, with register_globals enabled, allows remote attackers… CVSS 2.0MEDIUM 4.3
- TI-2005-03643 Cross-site scripting (XSS) vulnerability in the Search module in PmWiki up to 2.0.12… CVSS 2.0MEDIUM 4.3
- TI-2010-04471 Cross-site scripting (XSS) vulnerability in pmwiki.php in PmWiki 2.2.20 allows remote… CVSS 2.0MEDIUM 4.3
- TI-2006-04301 Cross-site scripting (XSS) vulnerability in PmWiki before 2.1.18 allows remote attackers… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2010-4662 · CVE Program
- CVE-2010-4662 · NVD
- FIRST EPSS
- GHSA-xg94-r739-55h8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences