Improper privilege management in consolekit
Priority MEDIUM 40CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-269.
Summary
In ConsoleKit before 0.4.2, an intended security policy restriction bypass was found. This flaw allows an authenticated system user to escalate their privileges by initiating a remote VNC session.
Why it matters now
EPSS 0.01208 68th percentileScored 2026-11-07
Fix Partial consolekit (consolekit): 0.4.2Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| consolekit | consolekit | before 0.4.2 | 0.4.2 | Patch available | CNA |
- consolekit Vendorconsolekit Affected before 0.4.2 Fixed in 0.4.2 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:consolekit_project:consolekit:*:*:*:*:*:*:*:* | before 0.4.2 | Vulnerable | Consolekit Project |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
- cpe:2.3:a:consolekit_project:consolekit:*:*:*:*:*:*:*:* Versions before 0.4.2 Vulnerable ·Consolekit Project
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
Remediation
- Fix · CNA consolekit (consolekit) Fixed in 0.4.2
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2010-4664
- 2026-10-03 Alias added: GHSA-qr44-jpvc-mm3p
References
Sources
- CVE-2010-4664 · CVE Program
- CVE-2010-4664 · NVD
- FIRST EPSS
- GHSA-qr44-jpvc-mm3p · GitHub Advisory Database · CC BY 4.0
- CVE-2010-4664 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences