chef-server-api/app/controllers/users.rb in the API in Chef before 0.9.0 does not require…
Priority LOW 32CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
chef-server-api/app/controllers/users.rb in the API in Chef before 0.9.0 does not require administrative privileges for the create, destroy, and update methods, which allows remote authenticated users to manage user accounts via requests to the /users URI.
Why it matters now
EPSS 0.0157 75th percentileScored 2026-11-07
Fix Fixed chef (RubyGems): 0.9.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | chef (RubyGems) | before 0.9.0 | 0.9.0 | Patch available | GHSA-f68m-q26r-64f6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- chef (RubyGems) Vendor— Affected before 0.9.0 Fixed in 0.9.0 Patch available GHSA-f68m-q26r-64f6
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opscode:chef:*:*:*:*:*:*:*:* | up to 0.8.10 | Vulnerable | Opscode |
| cpe:2.3:a:opscode:chef:0.7.2:*:*:*:*:*:*:* | 0.7.2 | Vulnerable | Opscode |
| cpe:2.3:a:opscode:chef:0.7.4:*:*:*:*:*:*:* | 0.7.4 | Vulnerable | Opscode |
| cpe:2.3:a:opscode:chef:0.7.6:*:*:*:*:*:*:* | 0.7.6 | Vulnerable | Opscode |
| cpe:2.3:a:opscode:chef:0.7.8:*:*:*:*:*:*:* | 0.7.8 | Vulnerable | Opscode |
| cpe:2.3:a:opscode:chef:0.7.10:*:*:*:*:*:*:* | 0.7.10 | Vulnerable | Opscode |
| cpe:2.3:a:opscode:chef:0.7.12:*:*:*:*:*:*:* | 0.7.12 | Vulnerable | Opscode |
| cpe:2.3:a:opscode:chef:0.7.14:*:*:*:*:*:*:* | 0.7.14 | Vulnerable | Opscode |
| cpe:2.3:a:opscode:chef:0.8.2:*:*:*:*:*:*:* | 0.8.2 | Vulnerable | Opscode |
| cpe:2.3:a:opscode:chef:0.8.4:*:*:*:*:*:*:* | 0.8.4 | Vulnerable | Opscode |
- cpe:2.3:a:opscode:chef:*:*:*:*:*:*:*:* Versions up to 0.8.10 Vulnerable ·Opscode
- cpe:2.3:a:opscode:chef:0.7.2:*:*:*:*:*:*:* Versions 0.7.2 Vulnerable ·Opscode
- cpe:2.3:a:opscode:chef:0.7.4:*:*:*:*:*:*:* Versions 0.7.4 Vulnerable ·Opscode
- cpe:2.3:a:opscode:chef:0.7.6:*:*:*:*:*:*:* Versions 0.7.6 Vulnerable ·Opscode
- cpe:2.3:a:opscode:chef:0.7.8:*:*:*:*:*:*:* Versions 0.7.8 Vulnerable ·Opscode
- cpe:2.3:a:opscode:chef:0.7.10:*:*:*:*:*:*:* Versions 0.7.10 Vulnerable ·Opscode
- cpe:2.3:a:opscode:chef:0.7.12:*:*:*:*:*:*:* Versions 0.7.12 Vulnerable ·Opscode
- cpe:2.3:a:opscode:chef:0.7.14:*:*:*:*:*:*:* Versions 0.7.14 Vulnerable ·Opscode
- cpe:2.3:a:opscode:chef:0.8.2:*:*:*:*:*:*:* Versions 0.8.2 Vulnerable ·Opscode
- cpe:2.3:a:opscode:chef:0.8.4:*:*:*:*:*:*:* Versions 0.8.4 Vulnerable ·Opscode
Remediation
- Fix · GHSA-f68m-q26r-64f6 chef (RubyGems) Fixed in 0.9.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2010-5142
- 2026-10-03 Alias added: GHSA-f68m-q26r-64f6
References
More Opscode Chef vulnerabilities
- TI-2011-04375 chef-server-api/app/controllers/clients.rb in Chef Server in Chef before 0.9.20, and… CVSS 2.0MEDIUM 6.5
- TI-2011-04374 chef-server-api/app/controllers/cookbooks.rb in Chef Server in Chef before 0.9.18, and… CVSS 2.0MEDIUM 5.5
Sources
- CVE-2010-5142 · CVE Program
- CVE-2010-5142 · NVD
- FIRST EPSS
- GHSA-f68m-q26r-64f6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences