Read the docs
TI-2010-05009 Aliases CVE-2010-5312GHSA-wcm2-9c89-wmfm

Cross-site scripting (XSS) vulnerability in jquery.ui.dialog.js in the Dialog widget in…

Priority MEDIUM 45CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 13 fixed, 10 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in jquery.ui.dialog.js in the Dialog widget in jQuery UI before 1.10.0 allows remote attackers to inject arbitrary web script or HTML via the title option.

Why it matters now

EPSS 0.18351 97th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial jquery-ui (npm): 1.10.0org.webjars.npm:jquery-ui (Maven): 1.10.0+2 more productsRed Hat: 2 advisoriesRed Hat: 13 fixed, 10 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—jquery-ui (npm)1.7.0 to before 1.10.01.10.0Patch availableGHSA-wcm2-9c89-wmfm
—org.webjars.npm:jquery-ui (Maven)1.7.0 to before 1.10.01.10.0Patch availableGHSA-wcm2-9c89-wmfm
—jQuery.UI.Combined (NuGet)1.7.0 to before 1.10.01.10.0Patch availableGHSA-wcm2-9c89-wmfm
—jquery-ui-rails (RubyGems)before 4.0.04.0.0Patch availableGHSA-wcm2-9c89-wmfm
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • jquery-ui (npm) Vendor— Affected 1.7.0 to before 1.10.0 Fixed in 1.10.0 Patch available GHSA-wcm2-9c89-wmfm
  • org.webjars.npm:jquery-ui (Maven) Vendor— Affected 1.7.0 to before 1.10.0 Fixed in 1.10.0 Patch available GHSA-wcm2-9c89-wmfm
  • jQuery.UI.Combined (NuGet) Vendor— Affected 1.7.0 to before 1.10.0 Fixed in 1.10.0 Patch available GHSA-wcm2-9c89-wmfm
  • jquery-ui-rails (RubyGems) Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available GHSA-wcm2-9c89-wmfm

CPE configurations NVD · 8

CPEVersionsRoleVendor
cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*7.0VulnerableDebian
cpe:2.3:a:jqueryui:jquery_ui:*:*:*:*:*:jquery:*:*before 1.10.0VulnerableJqueryui
cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*35VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:*36VulnerableFedoraproject
cpe:2.3:a:netapp:snapcenter:-:*:*:*:*:*:*:*not specified by NVDVulnerableNetApp
cpe:2.3:a:apache:drill:1.16.0:*:*:*:*:*:*:*1.16.0VulnerableApache
cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*7.0 to before 7.86VulnerableDrupal
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
  • cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
  • cpe:2.3:a:jqueryui:jquery_ui:*:*:*:*:*:jquery:*:* Versions before 1.10.0 Vulnerable ·Jqueryui
  • cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
  • cpe:2.3:a:netapp:snapcenter:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
  • cpe:2.3:a:apache:drill:1.16.0:*:*:*:*:*:*:* Versions 1.16.0 Vulnerable ·Apache
  • cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 7.0 to before 7.86 Vulnerable ·Drupal
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-wcm2-9c89-wmfm jquery-ui (npm) Fixed in 1.10.0 Advisory →
  • Fix · GHSA-wcm2-9c89-wmfm org.webjars.npm:jquery-ui (Maven) Fixed in 1.10.0 Advisory →
  • Fix · GHSA-wcm2-9c89-wmfm jQuery.UI.Combined (NuGet) Fixed in 1.10.0 Advisory →
  • Fix · GHSA-wcm2-9c89-wmfm jquery-ui-rails (RubyGems) Fixed in 4.0.0 Advisory →

Red Hat 2 advisories

  • RHSA-2015:1462 Released 2015-07-21 · Red Hat rating Moderate
    ipa security and bug fix update
    • Red Hat Enterprise Linux Desktop (v. 6) ipa-3.0.0-47.el6, ipa-client-3.0.0-47.el6, ipa-python-3.0.0-47.el6
    • Red Hat Enterprise Linux Desktop Optional (v. 6) ipa-admintools-3.0.0-47.el6, ipa-server-3.0.0-47.el6, ipa-server-selinux-3.0.0-47.el6 +1
    • Red Hat Enterprise Linux HPC Node (v. 6) ipa-3.0.0-47.el6, ipa-client-3.0.0-47.el6, ipa-python-3.0.0-47.el6
    • Red Hat Enterprise Linux HPC Node Optional (v. 6) ipa-admintools-3.0.0-47.el6, ipa-server-3.0.0-47.el6, ipa-server-selinux-3.0.0-47.el6 +1
    • Red Hat Enterprise Linux Server (v. 6) ipa-3.0.0-47.el6, ipa-admintools-3.0.0-47.el6, ipa-client-3.0.0-47.el6 +4
    • Red Hat Enterprise Linux Workstation (v. 6) ipa-3.0.0-47.el6, ipa-admintools-3.0.0-47.el6, ipa-client-3.0.0-47.el6 +4
  • RHSA-2015:0442 Released 2015-03-05 · Red Hat rating Moderate
    ipa security, bug fix, and enhancement update
    • Red Hat Enterprise Linux Client (v. 7) ipa-4.1.0-18.el7, ipa-client-4.1.0-18.el7, ipa-python-4.1.0-18.el7
    • Red Hat Enterprise Linux Client Optional (v. 7) ipa-admintools-4.1.0-18.el7, ipa-server-4.1.0-18.el7, ipa-server-trust-ad-4.1.0-18.el7
    • Red Hat Enterprise Linux ComputeNode (v. 7) ipa-4.1.0-18.el7, ipa-client-4.1.0-18.el7, ipa-python-4.1.0-18.el7
    • Red Hat Enterprise Linux ComputeNode Optional (v. 7) ipa-admintools-4.1.0-18.el7, ipa-server-4.1.0-18.el7, ipa-server-trust-ad-4.1.0-18.el7
    • Red Hat Enterprise Linux Server (v. 7) ipa-4.1.0-18.el7, ipa-admintools-4.1.0-18.el7, ipa-client-4.1.0-18.el7 +3
    • Red Hat Enterprise Linux Server Optional (v. 7) ipa-admintools-4.1.0-18.el7
    • Red Hat Enterprise Linux Workstation (v. 7) ipa-4.1.0-18.el7, ipa-admintools-4.1.0-18.el7, ipa-client-4.1.0-18.el7 +3

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
CloudForms Management Engine 5AffectedNo fix planned: Will not fix
OpenShift Enterprise 1AffectedNo fix planned: Will not fix
OpenStack ForemanAffectedNo fix planned: Will not fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux 7AffectedNo fix planned: Will not fix
Red Hat OpenShift Enterprise 2AffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 4AffectedNo fix planned: Will not fix
Red Hat Satellite 6AffectedNo fix planned: Will not fix
Red Hat Software CollectionsAffectedNo fix planned: Will not fix
Red Hat Subscription Asset ManagerAffectedNo fix planned: Will not fix
Red Hat Enterprise Linux Client (v. 7)Fixed RHSA-2015:0442
Red Hat Enterprise Linux Client Optional (v. 7)Fixed RHSA-2015:0442
Red Hat Enterprise Linux ComputeNode (v. 7)Fixed RHSA-2015:0442
Red Hat Enterprise Linux ComputeNode Optional (v. 7)Fixed RHSA-2015:0442
Red Hat Enterprise Linux Desktop (v. 6)Fixed RHSA-2015:1462
Red Hat Enterprise Linux Desktop Optional (v. 6)Fixed RHSA-2015:1462
Red Hat Enterprise Linux HPC Node (v. 6)Fixed RHSA-2015:1462
Red Hat Enterprise Linux HPC Node Optional (v. 6)Fixed RHSA-2015:1462
Red Hat Enterprise Linux Server (v. 6)Fixed RHSA-2015:1462
Red Hat Enterprise Linux Server (v. 7)Fixed RHSA-2015:0442
Red Hat Enterprise Linux Server Optional (v. 7)Fixed RHSA-2015:0442
Red Hat Enterprise Linux Workstation (v. 6)Fixed RHSA-2015:1462
Red Hat Enterprise Linux Workstation (v. 7)Fixed RHSA-2015:0442

Timeline

  1. 2026-10-02 Threatist record created from CVE-2010-5312
  2. 2026-10-03 Alias added: GHSA-wcm2-9c89-wmfm

References

Sources