Information Cards Module cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A vulnerability was found in Information Cards Module on simpleSAMLphp and classified as problematic. This issue affects some unknown processing. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.0 is able to address this issue. The identifier of the patch is f6bfea49ae16dc6e179df8306d39c3694f1ef186. It is recommended to upgrade the affected component. The identifier VDB-217661 was assigned to this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Information Cards Module | all versions | — | No fix listed | CNA |
| — | simplesamlphp/simplesamlphp-module-infocard (Packagist) | before 1.0 | 1.0 | Patch available | GHSA-2phw-rgr7-5pvh |
- Information Cards Module Vendor— Affected all versions Fixed in — No fix listed CNA
- simplesamlphp/simplesamlphp-module-infocard (Packagist) Vendor— Affected before 1.0 Fixed in 1.0 Patch available GHSA-2phw-rgr7-5pvh
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:information_cards_module:*:*:*:*:*:simplesamlphp:*:* | before 2010-07-29 | Vulnerable | simplesamlphp |
- cpe:2.3:a:simplesamlphp:information_cards_module:*:*:*:*:*:simplesamlphp:*:* Versions before 2010-07-29 Vulnerable ·simplesamlphp
Remediation
- Fix · GHSA-2phw-rgr7-5pvh simplesamlphp/simplesamlphp-module-infocard (Packagist) Fixed in 1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2010-10004
- 2026-10-03 Alias added: GHSA-2phw-rgr7-5pvh
References
Patch 2
Sources
- CVE-2010-10004 · CVE Program
- CVE-2010-10004 · NVD
- FIRST EPSS
- GHSA-2phw-rgr7-5pvh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences