Read the docs
TI-2010-05044 Aliases CVE-2010-10008GHSA-chgc-rqjr-46gg

simplesamlphp simplesamlphp-module-openidprovider trust.tpl.php cross site scripting

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in simplesamlphp simplesamlphp-module-openidprovider up to 0.8.x. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file templates/trust.tpl.php. The manipulation of the argument StateID leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.9.0 is able to address this issue. The identifier of the patch is 8365d48c863cf06ccf1465cc0a161cefae29d69d. It is recommended to upgrade the affected component. The identifier VDB-218473 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00589 48th percentileScored 2026-11-07
Fix Fixed simplesamlphp/simplesamlphp-module-openidprovider (Packagist): 0.9.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
simplesamlphpsimplesamlphp-module-openidprovider0.1; 0.2; 0.3; 0.4; 0.5; 0.6; 0.7; 0.8—No fix listedCNA
—simplesamlphp/simplesamlphp-module-openidprovider (Packagist)before 0.9.00.9.0Patch availableGHSA-chgc-rqjr-46gg
  • simplesamlphp-module-openidprovider Vendorsimplesamlphp Affected 0.1; 0.2; 0.3; 0.4; 0.5; 0.6; 0.7; 0.8 Fixed in — No fix listed CNA
  • simplesamlphp/simplesamlphp-module-openidprovider (Packagist) Vendor— Affected before 0.9.0 Fixed in 0.9.0 Patch available GHSA-chgc-rqjr-46gg

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:simplesamlphp:simplesamlphp-module-openidprovider:*:*:*:*:*:*:*:*before 0.9.0Vulnerablesimplesamlphp
  • cpe:2.3:a:simplesamlphp:simplesamlphp-module-openidprovider:*:*:*:*:*:*:*:* Versions before 0.9.0 Vulnerable ·simplesamlphp

Remediation

  • Fix · GHSA-chgc-rqjr-46gg simplesamlphp/simplesamlphp-module-openidprovider (Packagist) Fixed in 0.9.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2010-10008
  2. 2026-10-03 Alias added: GHSA-chgc-rqjr-46gg

References

Sources