Stars Alliance PsychoStats login.php cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability classified as problematic has been found in Stars Alliance PsychoStats up to 3.2.2a. This affects an unknown part of the file upload/admin/login.php. The manipulation of the argument ref leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 3.2.2b is able to address this issue. The identifier of the patch is 5d3b7311fd5085ec6ea1b1bfa9a05285964e07e4. It is recommended to upgrade the affected component. The identifier VDB-230265 was assigned to this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Stars Alliance | PsychoStats | 3.2.2a | — | No fix listed | CNA |
- PsychoStats VendorStars Alliance Affected 3.2.2a Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:psychostats:psychostats:*:*:*:*:*:*:*:* | before 3.2.2b | Vulnerable | Psychostats |
- cpe:2.3:a:psychostats:psychostats:*:*:*:*:*:*:*:* Versions before 3.2.2b Vulnerable ·Psychostats
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2010-10010
- 2026-10-03 Alias added: GHSA-j46h-rhfq-fcxj
References
More Psychostats vulnerabilities
- TI-2013-03242 SQL injection vulnerability in awards.php in PsychoStats 3.2.2b allows remote attackers… CVSS 2.0HIGH 7.5
- TI-2008-06114 Multiple SQL injection vulnerabilities in PsychoStats 2.3, 2.3.1, and 2.3.3 allow remote… CVSS 2.0HIGH 7.5
- TI-2007-02691 PsychoStats 3.0.6b and earlier allows remote attackers to obtain sensitive information… CVSS 2.0MEDIUM 5.0
- TI-2004-01294 Cross-site scripting (XSS) vulnerability in login.php in PsychoStats 2.2.4 Beta and… CVSS 2.0MEDIUM 4.3
- TI-2007-02821 Multiple cross-site scripting (XSS) vulnerabilities in PsychoStats 3.0.6b allow remote… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2010-10010 · CVE Program
- CVE-2010-10010 · NVD
- FIRST EPSS
- GHSA-j46h-rhfq-fcxj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences