Read the docs
TI-2011-00348 Aliases CVE-2011-0414GHSA-x6p7-4923-38gh

ISC BIND 9.7.1 through 9.7.2-P3, when configured as an authoritative server, allows…

Priority MEDIUM 46CWE-399Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Complete
Fix status
No fix listed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-399 and the CVSS impact.

Summary

ISC BIND 9.7.1 through 9.7.2-P3, when configured as an authoritative server, allows remote attackers to cause a denial of service (deadlock and daemon hang) by sending a query at the time of (1) an IXFR transfer or (2) a DDNS update.

Why it matters now

EPSS 0.13678 96th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 9

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.7.1:*:*:*:*:*:*:*9.7.1VulnerableISC
cpe:2.3:a:isc:bind:9.7.1:p1:*:*:*:*:*:*9.7.1 p1VulnerableISC
cpe:2.3:a:isc:bind:9.7.1:p2:*:*:*:*:*:*9.7.1 p2VulnerableISC
cpe:2.3:a:isc:bind:9.7.1:rc1:*:*:*:*:*:*9.7.1 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.7.2:*:*:*:*:*:*:*9.7.2VulnerableISC
cpe:2.3:a:isc:bind:9.7.2:p1:*:*:*:*:*:*9.7.2 p1VulnerableISC
cpe:2.3:a:isc:bind:9.7.2:p2:*:*:*:*:*:*9.7.2 p2VulnerableISC
cpe:2.3:a:isc:bind:9.7.2:p3:*:*:*:*:*:*9.7.2 p3VulnerableISC
cpe:2.3:a:isc:bind:9.7.2:rc1:*:*:*:*:*:*9.7.2 rc1VulnerableISC
  • cpe:2.3:a:isc:bind:9.7.1:*:*:*:*:*:*:* Versions 9.7.1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.1:p1:*:*:*:*:*:* Versions 9.7.1 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.1:p2:*:*:*:*:*:* Versions 9.7.1 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.1:rc1:*:*:*:*:*:* Versions 9.7.1 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.2:*:*:*:*:*:*:* Versions 9.7.2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.2:p1:*:*:*:*:*:* Versions 9.7.2 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.2:p2:*:*:*:*:*:* Versions 9.7.2 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.2:p3:*:*:*:*:*:* Versions 9.7.2 p3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.2:rc1:*:*:*:*:*:* Versions 9.7.2 rc1 Vulnerable ·ISC

Remediation

No fixed version listed by the sources yet.

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix yet
Not affected: 2 products
  • Red Hat Enterprise Linux 4
  • Red Hat Enterprise Linux 5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2011-0414
  2. 2026-10-03 Alias added: GHSA-x6p7-4923-38gh

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources