Ruby on Rails 2.1.x, 2.2.x, and 2.3.x before 2.3.11, and 3.x before 3.0.4, does not…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Tampering
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Ruby on Rails 2.1.x, 2.2.x, and 2.3.x before 2.3.11, and 3.x before 3.0.4, does not properly validate HTTP requests that contain an X-Requested-With header, which makes it easier for remote attackers to conduct cross-site request forgery (CSRF) attacks via forged (1) AJAX or (2) API requests that leverage "combinations of browser plugins and HTTP redirects," a related issue to CVE-2011-0696.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | actionpack (RubyGems) | 2.1.0 to before 2.3.11 | 2.3.11 | Patch available | GHSA-24fg-p96v-hxh8 |
| — | actionpack (RubyGems) | 3.0.0 to before 3.0.4 | 3.0.4 | Patch available | GHSA-24fg-p96v-hxh8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- actionpack (RubyGems) Vendor— Affected 2.1.0 to before 2.3.11 Fixed in 2.3.11 Patch available GHSA-24fg-p96v-hxh8
- actionpack (RubyGems) Vendor— Affected 3.0.0 to before 3.0.4 Fixed in 3.0.4 Patch available GHSA-24fg-p96v-hxh8
CPE configurations NVD · 24
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyonrails:rails:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.1.2:*:*:*:*:*:*:* | 2.1.2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.2.1:*:*:*:*:*:*:* | 2.2.1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.2.2:*:*:*:*:*:*:* | 2.2.2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.3.2:*:*:*:*:*:*:* | 2.3.2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.3.3:*:*:*:*:*:*:* | 2.3.3 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.3.4:*:*:*:*:*:*:* | 2.3.4 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:2.3.9:*:*:*:*:*:*:* | 2.3.9 | Vulnerable | Rails |
- cpe:2.3:a:rubyonrails:rails:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.2.2:*:*:*:*:*:*:* Versions 2.2.2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.3.2:*:*:*:*:*:*:* Versions 2.3.2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.3.3:*:*:*:*:*:*:* Versions 2.3.3 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.3.4:*:*:*:*:*:*:* Versions 2.3.4 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:2.3.9:*:*:*:*:*:*:* Versions 2.3.9 Vulnerable ·Rails
Show 14 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyonrails:rails:2.3.10:*:*:*:*:*:*:* | 2.3.10 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:*:*:*:*:*:*:* | 3.0.0 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:beta:*:*:*:*:*:* | 3.0.0 beta | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:beta2:*:*:*:*:*:* | 3.0.0 beta2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:beta3:*:*:*:*:*:* | 3.0.0 beta3 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:beta4:*:*:*:*:*:* | 3.0.0 beta4 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:rc:*:*:*:*:*:* | 3.0.0 rc | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:rc2:*:*:*:*:*:* | 3.0.0 rc2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.1:*:*:*:*:*:*:* | 3.0.1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.1:pre:*:*:*:*:*:* | 3.0.1 pre | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.2:*:*:*:*:*:*:* | 3.0.2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.2:pre:*:*:*:*:*:* | 3.0.2 pre | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.3:*:*:*:*:*:*:* | 3.0.3 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.4:rc1:*:*:*:*:*:* | 3.0.4 rc1 | Vulnerable | Rails |
- cpe:2.3:a:rubyonrails:rails:2.3.10:*:*:*:*:*:*:* Versions 2.3.10 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:*:*:*:*:*:*:* Versions 3.0.0 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:beta:*:*:*:*:*:* Versions 3.0.0 beta Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:beta2:*:*:*:*:*:* Versions 3.0.0 beta2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:beta3:*:*:*:*:*:* Versions 3.0.0 beta3 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:beta4:*:*:*:*:*:* Versions 3.0.0 beta4 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:rc:*:*:*:*:*:* Versions 3.0.0 rc Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:rc2:*:*:*:*:*:* Versions 3.0.0 rc2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.1:*:*:*:*:*:*:* Versions 3.0.1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.1:pre:*:*:*:*:*:* Versions 3.0.1 pre Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.2:*:*:*:*:*:*:* Versions 3.0.2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.2:pre:*:*:*:*:*:* Versions 3.0.2 pre Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.3:*:*:*:*:*:*:* Versions 3.0.3 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.4:rc1:*:*:*:*:*:* Versions 3.0.4 rc1 Vulnerable ·Rails
Remediation
- Fix · GHSA-24fg-p96v-hxh8 actionpack (RubyGems) Fixed in 2.3.11 Advisory →
- Fix · GHSA-24fg-p96v-hxh8 actionpack (RubyGems) Fixed in 3.0.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2011-0447
- 2026-10-03 Alias added: GHSA-24fg-p96v-hxh8
References
Patch 2
Advisory 5
Other 8
- ADV-2011-0587
- ADV-2011-0877
- https://github.com/rails/rails/commit/66ce3843d32e9f2ac3b1da20067af53019bbb034
- https://github.com/rails/rails/commit/7e86f9b4d2b7dfa974c10ae7e6d8ef90f3d77f06
- https://github.com/rails/rails
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2011-0447.yml
- https://web.archive.org/web/20120527023027/http://www.securityfocus.com/bid/46291
- https://web.archive.org/web/20170223045008/http://www.securitytracker.com/id?1025060
More Rails vulnerabilities
- TI-2014-00124 Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the… KEVCVSS 3.1HIGH 7.5
- TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
- TI-2016-00672 Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x… KEVCVSS 3.1HIGH 7.5
- TI-2019-03830 Command injection in Rails https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
- TI-2020-06581 Code injection in https://github.com/rails/rails CVSS 3.1HIGH 8.8
- TI-2013-00091 active_support/core_ext/hash/conversions.rb in Ruby on Rails before 2.3.15, 3.0.x before… CVSS 2.0HIGH 7.5
Sources
- CVE-2011-0447 · CVE Program
- CVE-2011-0447 · NVD
- FIRST EPSS
- GHSA-24fg-p96v-hxh8 · GitHub Advisory Database · CC BY 4.0
- CVE-2011-0447 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences