Ruby on Rails 3.0.x before 3.0.4 does not ensure that arguments to the limit function…
Priority LOW 37CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Ruby on Rails 3.0.x before 3.0.4 does not ensure that arguments to the limit function specify integer values, which makes it easier for remote attackers to conduct SQL injection attacks via a non-numeric argument.
Why it matters now
EPSS 0.02173 82nd percentileScored 2026-11-07
Fix Fixed activerecord (RubyGems): 3.0.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | activerecord (RubyGems) | 3.0.0 to before 3.0.4 | 3.0.4 | Patch available | GHSA-jmm9-2p29-vh2w |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- activerecord (RubyGems) Vendor— Affected 3.0.0 to before 3.0.4 Fixed in 3.0.4 Patch available GHSA-jmm9-2p29-vh2w
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyonrails:rails:3.0.0:*:*:*:*:*:*:* | 3.0.0 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:beta:*:*:*:*:*:* | 3.0.0 beta | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:beta2:*:*:*:*:*:* | 3.0.0 beta2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:beta3:*:*:*:*:*:* | 3.0.0 beta3 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:beta4:*:*:*:*:*:* | 3.0.0 beta4 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:rc:*:*:*:*:*:* | 3.0.0 rc | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:rc2:*:*:*:*:*:* | 3.0.0 rc2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.1:*:*:*:*:*:*:* | 3.0.1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.1:pre:*:*:*:*:*:* | 3.0.1 pre | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.2:*:*:*:*:*:*:* | 3.0.2 | Vulnerable | Rails |
- cpe:2.3:a:rubyonrails:rails:3.0.0:*:*:*:*:*:*:* Versions 3.0.0 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:beta:*:*:*:*:*:* Versions 3.0.0 beta Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:beta2:*:*:*:*:*:* Versions 3.0.0 beta2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:beta3:*:*:*:*:*:* Versions 3.0.0 beta3 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:beta4:*:*:*:*:*:* Versions 3.0.0 beta4 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:rc:*:*:*:*:*:* Versions 3.0.0 rc Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:rc2:*:*:*:*:*:* Versions 3.0.0 rc2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.1:*:*:*:*:*:*:* Versions 3.0.1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.1:pre:*:*:*:*:*:* Versions 3.0.1 pre Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.2:*:*:*:*:*:*:* Versions 3.0.2 Vulnerable ·Rails
Remediation
- Fix · GHSA-jmm9-2p29-vh2w activerecord (RubyGems) Fixed in 3.0.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2011-0448
- 2026-10-03 Alias added: GHSA-jmm9-2p29-vh2w
References
Patch 2
More Rails vulnerabilities
- TI-2014-00124 Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the… KEVCVSS 3.1HIGH 7.5
- TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
- TI-2016-00672 Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x… KEVCVSS 3.1HIGH 7.5
- TI-2019-03830 Command injection in Rails https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
- TI-2020-06581 Code injection in https://github.com/rails/rails CVSS 3.1HIGH 8.8
- TI-2013-00091 active_support/core_ext/hash/conversions.rb in Ruby on Rails before 2.3.15, 3.0.x before… CVSS 2.0HIGH 7.5
Sources
- CVE-2011-0448 · CVE Program
- CVE-2011-0448 · NVD
- FIRST EPSS
- GHSA-jmm9-2p29-vh2w · GitHub Advisory Database · CC BY 4.0
- CVE-2011-0448 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences