actionpack/lib/action_view/template/resolver.rb in Ruby on Rails 3.0.x before 3.0.4, when…
Priority LOW 38CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
actionpack/lib/action_view/template/resolver.rb in Ruby on Rails 3.0.x before 3.0.4, when a case-insensitive filesystem is used, does not properly implement filters associated with the list of available templates, which allows remote attackers to bypass intended access restrictions via an action name that uses an unintended case for alphabetic characters.
Why it matters now
EPSS 0.02498 84th percentileScored 2026-11-07
Fix Fixed actionpack (RubyGems): 3.0.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | actionpack (RubyGems) | 3.0.0 to before 3.0.4 | 3.0.4 | Patch available | GHSA-4ww3-3rxj-8v6q |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- actionpack (RubyGems) Vendor— Affected 3.0.0 to before 3.0.4 Fixed in 3.0.4 Patch available GHSA-4ww3-3rxj-8v6q
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyonrails:rails:3.0.0:*:*:*:*:*:*:* | 3.0.0 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:beta:*:*:*:*:*:* | 3.0.0 beta | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:beta2:*:*:*:*:*:* | 3.0.0 beta2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:beta3:*:*:*:*:*:* | 3.0.0 beta3 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:beta4:*:*:*:*:*:* | 3.0.0 beta4 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:rc:*:*:*:*:*:* | 3.0.0 rc | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.0:rc2:*:*:*:*:*:* | 3.0.0 rc2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.1:*:*:*:*:*:*:* | 3.0.1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.1:pre:*:*:*:*:*:* | 3.0.1 pre | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:3.0.2:*:*:*:*:*:*:* | 3.0.2 | Vulnerable | Rails |
- cpe:2.3:a:rubyonrails:rails:3.0.0:*:*:*:*:*:*:* Versions 3.0.0 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:beta:*:*:*:*:*:* Versions 3.0.0 beta Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:beta2:*:*:*:*:*:* Versions 3.0.0 beta2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:beta3:*:*:*:*:*:* Versions 3.0.0 beta3 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:beta4:*:*:*:*:*:* Versions 3.0.0 beta4 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:rc:*:*:*:*:*:* Versions 3.0.0 rc Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.0:rc2:*:*:*:*:*:* Versions 3.0.0 rc2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.1:*:*:*:*:*:*:* Versions 3.0.1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.1:pre:*:*:*:*:*:* Versions 3.0.1 pre Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:3.0.2:*:*:*:*:*:*:* Versions 3.0.2 Vulnerable ·Rails
Remediation
- Fix · GHSA-4ww3-3rxj-8v6q actionpack (RubyGems) Fixed in 3.0.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2011-0449
- 2026-10-03 Alias added: GHSA-4ww3-3rxj-8v6q
References
Other 6
- [rubyonrails-security] 20110209 Filter Problems on Case-Insensitive Filesystems
- ADV-2011-0877
- https://github.com/rails/rails/commit/6f80224057803f85b3f448936aae89e742452c3b
- https://github.com/rails/rails/tree/main/actionpack
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2011-0449.yml
- https://web.archive.org/web/20201207190612/http://securitytracker.com/id?1025061
More Rails vulnerabilities
- TI-2014-00124 Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the… KEVCVSS 3.1HIGH 7.5
- TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
- TI-2016-00672 Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x… KEVCVSS 3.1HIGH 7.5
- TI-2019-03830 Command injection in Rails https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
- TI-2020-06581 Code injection in https://github.com/rails/rails CVSS 3.1HIGH 8.8
- TI-2013-00091 active_support/core_ext/hash/conversions.rb in Ruby on Rails before 2.3.15, 3.0.x before… CVSS 2.0HIGH 7.5
Sources
- CVE-2011-0449 · CVE Program
- CVE-2011-0449 · NVD
- FIRST EPSS
- GHSA-4ww3-3rxj-8v6q · GitHub Advisory Database · CC BY 4.0
- CVE-2011-0449 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences