The sqlite3-ruby gem in the rubygem-sqlite3 package before 1.2.4-0.5.1 in SUSE Linux…
Priority LOW 11CWE-264Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
The sqlite3-ruby gem in the rubygem-sqlite3 package before 1.2.4-0.5.1 in SUSE Linux Enterprise (SLE) 11 SP1 uses weak permissions for unspecified files, which allows local users to gain privileges via unknown vectors.
Why it matters now
EPSS 0.00378 31st percentileScored 2026-11-07
Fix Fixed sqlite3-ruby (RubyGems): 1.2.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | sqlite3-ruby (RubyGems) | before 1.2.4 | 1.2.4 | Patch available | GHSA-6x46-7rrv-m4h8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- sqlite3-ruby (RubyGems) Vendor— Affected before 1.2.4 Fixed in 1.2.4 Patch available GHSA-6x46-7rrv-m4h8
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyforge:rubygem-sqlite3:*:*:*:*:*:*:*:* | up to 1.2.3 | Vulnerable | Rubyforge |
| cpe:2.3:a:rubyforge:rubygem-sqlite3:1.2.0:*:*:*:*:*:*:* | 1.2.0 | Vulnerable | Rubyforge |
| cpe:2.3:a:rubyforge:rubygem-sqlite3:1.2.1:*:*:*:*:*:*:* | 1.2.1 | Vulnerable | Rubyforge |
| cpe:2.3:a:rubyforge:rubygem-sqlite3:1.2.2:*:*:*:*:*:*:* | 1.2.2 | Vulnerable | Rubyforge |
| cpe:2.3:o:novell:suse_linux_enterprise:11:sp1:*:*:*:*:*:* | 11 sp1 | Vulnerable | Novell |
- cpe:2.3:a:rubyforge:rubygem-sqlite3:*:*:*:*:*:*:*:* Versions up to 1.2.3 Vulnerable ·Rubyforge
- cpe:2.3:a:rubyforge:rubygem-sqlite3:1.2.0:*:*:*:*:*:*:* Versions 1.2.0 Vulnerable ·Rubyforge
- cpe:2.3:a:rubyforge:rubygem-sqlite3:1.2.1:*:*:*:*:*:*:* Versions 1.2.1 Vulnerable ·Rubyforge
- cpe:2.3:a:rubyforge:rubygem-sqlite3:1.2.2:*:*:*:*:*:*:* Versions 1.2.2 Vulnerable ·Rubyforge
- cpe:2.3:o:novell:suse_linux_enterprise:11:sp1:*:*:*:*:*:* Versions 11 sp1 Vulnerable ·Novell
Remediation
- Fix · GHSA-6x46-7rrv-m4h8 sqlite3-ruby (RubyGems) Fixed in 1.2.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2011-0995
- 2026-10-03 Alias added: GHSA-6x46-7rrv-m4h8
References
Other 9
- https://bugzilla.novell.com/show_bug.cgi?id=685928
- 72180
- http://support.novell.com/security/cve/CVE-2011-0995.html
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/sqlite3-ruby/CVE-2011-0995.yml
- https://github.com/schuyler/sqlite3-ruby
- https://web.archive.org/web/20110513184951/http://support.novell.com/security/cve/CVE-2011-0995.html
- https://web.archive.org/web/20200229151908/http://www.securityfocus.com/bid/47694
- https://web.archive.org/web/20201106213407/https://bugzilla.novell.com/show_bug.cgi?id=685928
- https://www.suse.com/security/cve/CVE-2011-0995.html
Sources
- CVE-2011-0995 · CVE Program
- CVE-2011-0995 · NVD
- FIRST EPSS
- GHSA-6x46-7rrv-m4h8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences