Improper input validation in smarty3
Priority MEDIUM 45CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
The $smarty.template variable in Smarty3 allows attackers to possibly execute arbitrary PHP code via the sysplugins/smarty_internal_compile_private_special_variable.php file.
Why it matters now
EPSS 0.01613 76th percentileScored 2026-11-07
Fix Fixed smarty/smarty (Packagist): 3.0.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| smarty3 | smarty3 | 3 | — | No fix listed | CNA |
| — | smarty/smarty (Packagist) | before 3.0.7 | 3.0.7 | Patch available | GHSA-6frx-2r5w-c524 |
- smarty3 Vendorsmarty3 Affected 3 Fixed in — No fix listed CNA
- smarty/smarty (Packagist) Vendor— Affected before 3.0.7 Fixed in 3.0.7 Patch available GHSA-6frx-2r5w-c524
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:smarty:smarty:*:*:*:*:*:*:*:* | 3.0.0 to before 3.0.7 | Vulnerable | smarty-php |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:smarty:smarty:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.0.7 Vulnerable ·smarty-php
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-6frx-2r5w-c524 smarty/smarty (Packagist) Fixed in 3.0.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2011-1028
- 2026-10-03 Alias added: GHSA-6frx-2r5w-c524
References
Advisory 3
Other 5
- https://access.redhat.com/security/cve/cve-2011-1028
- https://github.com/smarty-php/smarty/commit/0154f17de2b2dd16ff9c016923015ac19af9c0cb
- https://github.com/smarty-php/smarty
- https://web.archive.org/web/20110609032516/http://smarty-php.googlecode.com/svn/trunk/distribution/change_log.txt
- https://www.smarty.net/forums/viewtopic.php?t=18815
Sources
- CVE-2011-1028 · CVE Program
- CVE-2011-1028 · NVD
- FIRST EPSS
- GHSA-6frx-2r5w-c524 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences