Cross-site scripting (XSS) vulnerability in…
Priority LOW 22CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in skins/plone_templates/default_error_message.pt in Plone before 2.5.3 allows remote attackers to inject arbitrary web script or HTML via the type_name parameter to Members/ipa/createObject.
Why it matters now
EPSS 0.01153 67th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed plone (PyPI): 2.5.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | plone (PyPI) | before 2.5.3 | 2.5.3 | Patch available | GHSA-cvwc-g7fw-7xrj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- plone (PyPI) Vendor— Affected before 2.5.3 Fixed in 2.5.3 Patch available GHSA-cvwc-g7fw-7xrj
CPE configurations NVD · 21
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:plone:plone:*:*:*:*:*:*:*:* | up to 2.5.2 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:1.0:*:*:*:*:*:*:* | 1.0 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:1.0.1:*:*:*:*:*:*:* | 1.0.1 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:1.0.2:*:*:*:*:*:*:* | 1.0.2 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:1.0.3:*:*:*:*:*:*:* | 1.0.3 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:1.0.4:*:*:*:*:*:*:* | 1.0.4 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:1.0.5:*:*:*:*:*:*:* | 1.0.5 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:1.0.6:*:*:*:*:*:*:* | 1.0.6 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:2.0:*:*:*:*:*:*:* | 2.0 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | plone |
- cpe:2.3:a:plone:plone:*:*:*:*:*:*:*:* Versions up to 2.5.2 Vulnerable ·plone
- cpe:2.3:a:plone:plone:1.0:*:*:*:*:*:*:* Versions 1.0 Vulnerable ·plone
- cpe:2.3:a:plone:plone:1.0.1:*:*:*:*:*:*:* Versions 1.0.1 Vulnerable ·plone
- cpe:2.3:a:plone:plone:1.0.2:*:*:*:*:*:*:* Versions 1.0.2 Vulnerable ·plone
- cpe:2.3:a:plone:plone:1.0.3:*:*:*:*:*:*:* Versions 1.0.3 Vulnerable ·plone
- cpe:2.3:a:plone:plone:1.0.4:*:*:*:*:*:*:* Versions 1.0.4 Vulnerable ·plone
- cpe:2.3:a:plone:plone:1.0.5:*:*:*:*:*:*:* Versions 1.0.5 Vulnerable ·plone
- cpe:2.3:a:plone:plone:1.0.6:*:*:*:*:*:*:* Versions 1.0.6 Vulnerable ·plone
- cpe:2.3:a:plone:plone:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·plone
- cpe:2.3:a:plone:plone:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·plone
Show 11 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:plone:plone:2.0.2:*:*:*:*:*:*:* | 2.0.2 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:2.0.3:*:*:*:*:*:*:* | 2.0.3 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:2.0.4:*:*:*:*:*:*:* | 2.0.4 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:2.0.5:*:*:*:*:*:*:* | 2.0.5 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:2.1:*:*:*:*:*:*:* | 2.1 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:2.1.2:*:*:*:*:*:*:* | 2.1.2 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:2.1.3:*:*:*:*:*:*:* | 2.1.3 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:2.1.4:*:*:*:*:*:*:* | 2.1.4 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:2.5:*:*:*:*:*:*:* | 2.5 | Vulnerable | plone |
| cpe:2.3:a:plone:plone:2.5.1:*:*:*:*:*:*:* | 2.5.1 | Vulnerable | plone |
- cpe:2.3:a:plone:plone:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·plone
- cpe:2.3:a:plone:plone:2.0.3:*:*:*:*:*:*:* Versions 2.0.3 Vulnerable ·plone
- cpe:2.3:a:plone:plone:2.0.4:*:*:*:*:*:*:* Versions 2.0.4 Vulnerable ·plone
- cpe:2.3:a:plone:plone:2.0.5:*:*:*:*:*:*:* Versions 2.0.5 Vulnerable ·plone
- cpe:2.3:a:plone:plone:2.1:*:*:*:*:*:*:* Versions 2.1 Vulnerable ·plone
- cpe:2.3:a:plone:plone:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·plone
- cpe:2.3:a:plone:plone:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·plone
- cpe:2.3:a:plone:plone:2.1.3:*:*:*:*:*:*:* Versions 2.1.3 Vulnerable ·plone
- cpe:2.3:a:plone:plone:2.1.4:*:*:*:*:*:*:* Versions 2.1.4 Vulnerable ·plone
- cpe:2.3:a:plone:plone:2.5:*:*:*:*:*:*:* Versions 2.5 Vulnerable ·plone
- cpe:2.3:a:plone:plone:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·plone
Remediation
- Fix · GHSA-cvwc-g7fw-7xrj plone (PyPI) Fixed in 2.5.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Enterprise Linux 5
Timeline
- 2026-10-02 Threatist record created from CVE-2011-1340
- 2026-10-03 Alias added: GHSA-cvwc-g7fw-7xrj
References
More Plone vulnerabilities
- TI-2011-03162 Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through… CVSS 2.0HIGH 9.3
- TI-2021-13226 An issue in Plone CMS v. CVSS 3.1HIGH 8.8
- TI-2024-15757 The HTTP PUT and DELETE methods are enabled in the Plone official Docker version 5.2.13… CVSS 3.1HIGH 7.5
- TI-2021-12911 Plone through 5.2.4 allows remote authenticated managers to perform disk I/O via crafted… CVSS 3.1CRITICAL 9.9
- TI-2020-17872 The official plone Docker images before version of 4.3.18-alpine (Alpine specific)… CVSS 3.1CRITICAL 9.8
- TI-2020-06422 A privilege escalation issue in plone.app.contenttypes in Plone 4.3 through 5.2.1 allows… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2011-1340 · CVE Program
- CVE-2011-1340 · NVD
- FIRST EPSS
- GHSA-cvwc-g7fw-7xrj · GitHub Advisory Database · CC BY 4.0
- CVE-2011-1340 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences