A memory leak in rsyslog before 5.7.6 was found in the way deamon processed log messages…
Priority LOW 25CWE-772Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-772.
Summary
A memory leak in rsyslog before 5.7.6 was found in the way deamon processed log messages are logged when $RepeatedMsgReduction was enabled. A local attacker could use this flaw to cause a denial of the rsyslogd daemon service by crashing the service via a sequence of repeated log messages sent within short periods of time.
Why it matters now
EPSS 0.00476 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed rsyslog (rsyslog): 5.7.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| rsyslog | rsyslog | before 5.7.6 | 5.7.6 | Patch available | CNA |
- rsyslog Vendorrsyslog Affected before 5.7.6 Fixed in 5.7.6 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rsyslog:rsyslog:*:*:*:*:*:*:*:* | before 5.7.6 | Vulnerable | rsyslog |
| cpe:2.3:o:opensuse:opensuse:11.4:*:*:*:*:*:*:* | 11.4 | Vulnerable | openSUSE |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:rsyslog:rsyslog:*:*:*:*:*:*:*:* Versions before 5.7.6 Vulnerable ·rsyslog
- cpe:2.3:o:opensuse:opensuse:11.4:*:*:*:*:*:*:* Versions 11.4 Vulnerable ·openSUSE
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA rsyslog (rsyslog) Fixed in 5.7.6
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
Timeline
- 2026-10-02 Threatist record created from CVE-2011-1488
- 2026-10-03 Alias added: GHSA-3php-pxg5-vr69
References
Advisory 3
More Rsyslog vulnerabilities
- TI-2019-12711 An issue was discovered in Rsyslog v8.1908.0. CVSS 3.1CRITICAL 9.8
- TI-2019-12712 An issue was discovered in Rsyslog v8.1908.0. CVSS 3.1CRITICAL 9.8
- TI-2019-12710 contrib/pmdb2diag/pmdb2diag.c in Rsyslog v8.1908.0 allows out-of-bounds access because the level length is mishandled. CVSS 3.1CRITICAL 9.8
- TI-2017-09315 The zmq3 input and output modules in rsyslog before 8.28.0 interpreted description fields… CVSS 3.0CRITICAL 9.8
- TI-2022-08713 Buffer overflow in TCP syslog server (receiver) components in rsyslog CVSS 3.1HIGH 8.1
- TI-2014-02955 rsyslog before 7.6.6 and 8.x before 8.4.1 and sysklogd 1.5 and earlier allows remote… CVSS 2.0HIGH 7.5
Sources
- CVE-2011-1488 · CVE Program
- CVE-2011-1488 · NVD
- FIRST EPSS
- GHSA-3php-pxg5-vr69 · GitHub Advisory Database · CC BY 4.0
- CVE-2011-1488 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences