Read the docs
TI-2011-02158 Aliases CVE-2011-2464GHSA-pgw8-84wx-gr5w

Unspecified vulnerability in ISC BIND 9 9.6.x before 9.6-ESV-R4-P3, 9.7.x before…

Priority MEDIUM 41Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · Partial
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat.

Summary

Unspecified vulnerability in ISC BIND 9 9.6.x before 9.6-ESV-R4-P3, 9.7.x before 9.7.3-P3, and 9.8.x before 9.8.0-P4 allows remote attackers to cause a denial of service (named daemon crash) via a crafted UPDATE request.

Why it matters now

EPSS 0.19265 97th percentileScored 2026-11-07
Fix Fixed Red Hat: 1 advisory

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 41

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.6:*:*:*:*:*:*:*9.6VulnerableISC
cpe:2.3:a:isc:bind:9.6.0:*:*:*:*:*:*:*9.6.0VulnerableISC
cpe:2.3:a:isc:bind:9.6.0:p1:*:*:*:*:*:*9.6.0 p1VulnerableISC
cpe:2.3:a:isc:bind:9.6.0:rc1:*:*:*:*:*:*9.6.0 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.6.0:rc2:*:*:*:*:*:*9.6.0 rc2VulnerableISC
cpe:2.3:a:isc:bind:9.6.1:*:*:*:*:*:*:*9.6.1VulnerableISC
cpe:2.3:a:isc:bind:9.6.1:p1:*:*:*:*:*:*9.6.1 p1VulnerableISC
cpe:2.3:a:isc:bind:9.6.1:p2:*:*:*:*:*:*9.6.1 p2VulnerableISC
cpe:2.3:a:isc:bind:9.6.1:p3:*:*:*:*:*:*9.6.1 p3VulnerableISC
cpe:2.3:a:isc:bind:9.6.1:rc1:*:*:*:*:*:*9.6.1 rc1VulnerableISC
  • cpe:2.3:a:isc:bind:9.6:*:*:*:*:*:*:* Versions 9.6 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.0:*:*:*:*:*:*:* Versions 9.6.0 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.0:p1:*:*:*:*:*:* Versions 9.6.0 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.0:rc1:*:*:*:*:*:* Versions 9.6.0 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.0:rc2:*:*:*:*:*:* Versions 9.6.0 rc2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.1:*:*:*:*:*:*:* Versions 9.6.1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.1:p1:*:*:*:*:*:* Versions 9.6.1 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.1:p2:*:*:*:*:*:* Versions 9.6.1 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.1:p3:*:*:*:*:*:* Versions 9.6.1 p3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.1:rc1:*:*:*:*:*:* Versions 9.6.1 rc1 Vulnerable ·ISC
Show 31 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.6.2:*:*:*:*:*:*:*9.6.2VulnerableISC
cpe:2.3:a:isc:bind:9.6.2:rc1:*:*:*:*:*:*9.6.2 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.6.3:*:*:*:*:*:*:*9.6.3VulnerableISC
cpe:2.3:a:isc:bind:9.6.3:rc1:*:*:*:*:*:*9.6.3 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:*:*:*:*:*:*:*9.7.0VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:b1:*:*:*:*:*:*9.7.0 b1VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:p1:*:*:*:*:*:*9.7.0 p1VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:p2:*:*:*:*:*:*9.7.0 p2VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:rc1:*:*:*:*:*:*9.7.0 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.7.0:rc2:*:*:*:*:*:*9.7.0 rc2VulnerableISC
cpe:2.3:a:isc:bind:9.7.1:*:*:*:*:*:*:*9.7.1VulnerableISC
cpe:2.3:a:isc:bind:9.7.1:p1:*:*:*:*:*:*9.7.1 p1VulnerableISC
cpe:2.3:a:isc:bind:9.7.1:p2:*:*:*:*:*:*9.7.1 p2VulnerableISC
cpe:2.3:a:isc:bind:9.7.1:rc1:*:*:*:*:*:*9.7.1 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.7.2:*:*:*:*:*:*:*9.7.2VulnerableISC
cpe:2.3:a:isc:bind:9.7.2:p1:*:*:*:*:*:*9.7.2 p1VulnerableISC
cpe:2.3:a:isc:bind:9.7.2:p2:*:*:*:*:*:*9.7.2 p2VulnerableISC
cpe:2.3:a:isc:bind:9.7.2:p3:*:*:*:*:*:*9.7.2 p3VulnerableISC
cpe:2.3:a:isc:bind:9.7.2:rc1:*:*:*:*:*:*9.7.2 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.7.2b1:*:*:*:*:*:*:*9.7.2b1VulnerableISC
cpe:2.3:a:isc:bind:9.7.3:*:*:*:*:*:*:*9.7.3VulnerableISC
cpe:2.3:a:isc:bind:9.7.3:b1:*:*:*:*:*:*9.7.3 b1VulnerableISC
cpe:2.3:a:isc:bind:9.7.3:p1:*:*:*:*:*:*9.7.3 p1VulnerableISC
cpe:2.3:a:isc:bind:9.7.3:rc1:*:*:*:*:*:*9.7.3 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.8.0:*:*:*:*:*:*:*9.8.0VulnerableISC
cpe:2.3:a:isc:bind:9.8.0:a1:*:*:*:*:*:*9.8.0 a1VulnerableISC
cpe:2.3:a:isc:bind:9.8.0:b1:*:*:*:*:*:*9.8.0 b1VulnerableISC
cpe:2.3:a:isc:bind:9.8.0:p1:*:*:*:*:*:*9.8.0 p1VulnerableISC
cpe:2.3:a:isc:bind:9.8.0:p2:*:*:*:*:*:*9.8.0 p2VulnerableISC
cpe:2.3:a:isc:bind:9.8.0:rc1:*:*:*:*:*:*9.8.0 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.8.1:b1:*:*:*:*:*:*9.8.1 b1VulnerableISC
  • cpe:2.3:a:isc:bind:9.6.2:*:*:*:*:*:*:* Versions 9.6.2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.2:rc1:*:*:*:*:*:* Versions 9.6.2 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.3:*:*:*:*:*:*:* Versions 9.6.3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.6.3:rc1:*:*:*:*:*:* Versions 9.6.3 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:*:*:*:*:*:*:* Versions 9.7.0 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:b1:*:*:*:*:*:* Versions 9.7.0 b1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:p1:*:*:*:*:*:* Versions 9.7.0 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:p2:*:*:*:*:*:* Versions 9.7.0 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:rc1:*:*:*:*:*:* Versions 9.7.0 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.0:rc2:*:*:*:*:*:* Versions 9.7.0 rc2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.1:*:*:*:*:*:*:* Versions 9.7.1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.1:p1:*:*:*:*:*:* Versions 9.7.1 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.1:p2:*:*:*:*:*:* Versions 9.7.1 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.1:rc1:*:*:*:*:*:* Versions 9.7.1 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.2:*:*:*:*:*:*:* Versions 9.7.2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.2:p1:*:*:*:*:*:* Versions 9.7.2 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.2:p2:*:*:*:*:*:* Versions 9.7.2 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.2:p3:*:*:*:*:*:* Versions 9.7.2 p3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.2:rc1:*:*:*:*:*:* Versions 9.7.2 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.2b1:*:*:*:*:*:*:* Versions 9.7.2b1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.3:*:*:*:*:*:*:* Versions 9.7.3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.3:b1:*:*:*:*:*:* Versions 9.7.3 b1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.3:p1:*:*:*:*:*:* Versions 9.7.3 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.7.3:rc1:*:*:*:*:*:* Versions 9.7.3 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.8.0:*:*:*:*:*:*:* Versions 9.8.0 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.8.0:a1:*:*:*:*:*:* Versions 9.8.0 a1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.8.0:b1:*:*:*:*:*:* Versions 9.8.0 b1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.8.0:p1:*:*:*:*:*:* Versions 9.8.0 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.8.0:p2:*:*:*:*:*:* Versions 9.8.0 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.8.0:rc1:*:*:*:*:*:* Versions 9.8.0 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.8.1:b1:*:*:*:*:*:* Versions 9.8.1 b1 Vulnerable ·ISC

Remediation

Red Hat 1 advisory

  • RHSA-2011:0926 Released 2011-07-07 · Red Hat rating Important
    bind security update
    • Red Hat Enterprise Linux (v. 5.6.z server) bind97-32:9.7.0-6.P2.el5_6.3, bind97-32:9.7.0-6.P2.el5_6.3.i386, bind97-32:9.7.0-6.P2.el5_6.3.ia64 +17
    • Red Hat Enterprise Linux Server (v. 6) bind-32:9.7.3-2.el6_1.P3.2, bind-chroot-32:9.7.3-2.el6_1.P3.2, bind-libs-32:9.7.3-2.el6_1.P3.2 +2
    • Red Hat Enterprise Linux Server Optional (v. 6) bind-32:9.7.3-2.el6_1.P3.2, bind-devel-32:9.7.3-2.el6_1.P3.2, bind-devel-32:9.7.3-2.el6_1.P3.2.ppc +1

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux (v. 5.6.z server)Fixed RHSA-2011:0926
Red Hat Enterprise Linux Server (v. 6)Fixed RHSA-2011:0926
Red Hat Enterprise Linux Server Optional (v. 6)Fixed RHSA-2011:0926
Not affected: 2 products
  • Red Hat Enterprise Linux 4
  • Red Hat Enterprise Linux 5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2011-2464
  2. 2026-10-03 Alias added: GHSA-pgw8-84wx-gr5w

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources