Apache Tomcat 7.0.x before 7.0.17 permits web applications to replace an XML parser used…
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Apache Tomcat 7.0.x before 7.0.17 permits web applications to replace an XML parser used for other web applications, which allows local users to read or modify the (1) web.xml, (2) context.xml, or (3) tld files of arbitrary web applications via a crafted application that is loaded earlier than the target application. NOTE: this vulnerability exists because of a CVE-2009-0783 regression.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.tomcat:tomcat (Maven) | 7.0.0 to before 7.0.17 | 7.0.17 | Patch available | GHSA-r7c8-hghc-2mp8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.tomcat:tomcat (Maven) Vendor— Affected 7.0.0 to before 7.0.17 Fixed in 7.0.17 Patch available GHSA-r7c8-hghc-2mp8
CPE configurations NVD · 16
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:tomcat:7.0.0:*:*:*:*:*:*:* | 7.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:7.0.0:beta:*:*:*:*:*:* | 7.0.0 beta | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:7.0.1:*:*:*:*:*:*:* | 7.0.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:7.0.2:*:*:*:*:*:*:* | 7.0.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:7.0.3:*:*:*:*:*:*:* | 7.0.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:7.0.4:*:*:*:*:*:*:* | 7.0.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:7.0.5:*:*:*:*:*:*:* | 7.0.5 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:7.0.6:*:*:*:*:*:*:* | 7.0.6 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:7.0.7:*:*:*:*:*:*:* | 7.0.7 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:7.0.8:*:*:*:*:*:*:* | 7.0.8 | Vulnerable | Apache |
- cpe:2.3:a:apache:tomcat:7.0.0:*:*:*:*:*:*:* Versions 7.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:7.0.0:beta:*:*:*:*:*:* Versions 7.0.0 beta Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:7.0.1:*:*:*:*:*:*:* Versions 7.0.1 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:7.0.2:*:*:*:*:*:*:* Versions 7.0.2 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:7.0.3:*:*:*:*:*:*:* Versions 7.0.3 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:7.0.4:*:*:*:*:*:*:* Versions 7.0.4 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:7.0.5:*:*:*:*:*:*:* Versions 7.0.5 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:7.0.6:*:*:*:*:*:*:* Versions 7.0.6 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:7.0.7:*:*:*:*:*:*:* Versions 7.0.7 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:7.0.8:*:*:*:*:*:*:* Versions 7.0.8 Vulnerable ·Apache
Show 6 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:tomcat:7.0.9:*:*:*:*:*:*:* | 7.0.9 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:7.0.10:*:*:*:*:*:*:* | 7.0.10 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:7.0.11:*:*:*:*:*:*:* | 7.0.11 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:7.0.12:*:*:*:*:*:*:* | 7.0.12 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:7.0.13:*:*:*:*:*:*:* | 7.0.13 | Vulnerable | Apache |
| cpe:2.3:a:apache:tomcat:7.0.14:*:*:*:*:*:*:* | 7.0.14 | Vulnerable | Apache |
- cpe:2.3:a:apache:tomcat:7.0.9:*:*:*:*:*:*:* Versions 7.0.9 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:7.0.10:*:*:*:*:*:*:* Versions 7.0.10 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:7.0.11:*:*:*:*:*:*:* Versions 7.0.11 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:7.0.12:*:*:*:*:*:*:* Versions 7.0.12 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:7.0.13:*:*:*:*:*:*:* Versions 7.0.13 Vulnerable ·Apache
- cpe:2.3:a:apache:tomcat:7.0.14:*:*:*:*:*:*:* Versions 7.0.14 Vulnerable ·Apache
Remediation
- Fix · GHSA-r7c8-hghc-2mp8 org.apache.tomcat:tomcat (Maven) Fixed in 7.0.17 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
Timeline
- 2026-10-02 Threatist record created from CVE-2011-2481
- 2026-10-03 Alias added: GHSA-r7c8-hghc-2mp8
References
Patch 3
More Apache Tomcat vulnerabilities
- TI-2025-18529 Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT KEVCVSS 3.1CRITICAL 10.0
- TI-2020-01862 Improper privilege management in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
- TI-2016-07192 Improper access control in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
- TI-2017-09342 Unrestricted file upload in Apache Tomcat KEVCVSS 3.1HIGH 8.1
- TI-2017-09340 Unrestricted file upload in Apache Tomcat KEVCVSS 3.1HIGH 8.1
- TI-2026-26741 Apache Tomcat: Fix for CVE-2026-29146 allowed bypass of EncryptInterceptor KEVCVSS 3.1HIGH 7.5
Sources
- CVE-2011-2481 · CVE Program
- CVE-2011-2481 · NVD
- FIRST EPSS
- GHSA-r7c8-hghc-2mp8 · GitHub Advisory Database · CC BY 4.0
- CVE-2011-2481 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences